# CVE-2026-54690: datamodel-code-generator vulnerable to SSRF via JSON-Schema `$ref` to HTTP URL (silent by default)

> Attackers can trigger server-side request forgery by providing malicious JSON Schema references, potentially accessing internal resources during code generation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-954p-556p-r752, MINI-qxhx-gfp6-hjpr, PYSEC-2026-3560

## What is CVE-2026-54690?

CVE-2026-54690 is a high-severity server-side request forgery vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

datamodel-code-generator generates Pydantic v2 models, dataclasses, TypedDict, and msgspec.Struct from OpenAPI, JSON Schema, GraphQL, Avro, Protobuf, and raw JSON, YAML, or CSV. From 0.9.1 until 0.61.0, datamodel-code-generator silently dereferences attacker-controlled JSON Schema $ref HTTP or HTTPS URLs in src/datamodel_code_generator/parser/jsonschema.py through _get_ref_body, and the --allow-remote-refs gate can warn instead of blocking, allowing server-side request forgery through src/datamodel_code_generator/http.py. This issue is fixed in version 0.61.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54690?

3 open source packages ship an affected version, including datamodel-code-generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |

Products: Koxudaxi Datamodel-Code-Generator.

## How do I fix CVE-2026-54690?

Upgrade datamodel-code-generator to 0.61.0 or later.

## Is CVE-2026-54690 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54690 exists.

## Other vulnerabilities in koxudaxi datamodel-code-generator

- [CVE-2026-54653](https://insights.sbomify.com/CVE-2026-54653/): `datamodel-code-generator` vulnerable to code injection in via attacker-controlled `default_factory` schema field (high 8.8)
- [CVE-2026-54656](https://insights.sbomify.com/CVE-2026-54656/): `datamodel-code-generator` vulnerable to code execution on import via unescaped `validators` entries in --extra-template-data (high 7.8)
- [CVE-2026-55389](https://insights.sbomify.com/CVE-2026-55389/): datamodel-code-generator vulnerable to arbitrary local file read via JSON-Schema `$ref` (`file://` and `../` traversal), bypassing `--no-allow-remote-refs` (high 7.5)
- [CVE-2026-55391](https://insights.sbomify.com/CVE-2026-55391/): datamodel-code-generator vulnerable to SSRF protection bypass via DNS rebinding (high 7.5)
- [CVE-2026-55415](https://insights.sbomify.com/CVE-2026-55415/): datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54690 and fix it if it is affected.

What it is: CVE-2026-54690 is a high-severity server-side request forgery vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54690 exists.

Affected packages and fixed versions:
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54690/ (Markdown: https://insights.sbomify.com/CVE-2026-54690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54690
- OSV: https://osv.dev/vulnerability/CVE-2026-54690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54690/
Summaries are generated and may contain mistakes; the official description above is the record.
