# CVE-2026-54691: datamodel-code-generator vulnerable to SSRF via --url: no host/IP validation, follows redirects

> Attackers can exploit the --url flag to perform server-side request forgery, accessing internal network resources and metadata services.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-rfr2-mq9m-x2qx, MINI-x4q8-2rhc-3q8h, PYSEC-2026-3564

## What is CVE-2026-54691?

CVE-2026-54691 is a high-severity server-side request forgery vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

datamodel-code-generator generates Python data models from schema definitions. From 0.9.1 until 0.61.0, src/datamodel_code_generator/http.py http.get_body accepts --url targets and redirect chain targets without host/IP validation, allowing server-side request forgery against loopback, private, link-local, metadata, and other network-accessible resources. This issue is fixed in version 0.61.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54691?

3 open source packages ship an affected version, including datamodel-code-generator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |
| `datamodel-code-generator` | PyPI | From 0.9.1 | 0.61.0 |

## How do I fix CVE-2026-54691?

Upgrade datamodel-code-generator to 0.61.0 or later.

## Is CVE-2026-54691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54691 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54691 and fix it if it is affected.

What it is: CVE-2026-54691 is a high-severity server-side request forgery vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54691 exists.

Affected packages and fixed versions:
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0
- datamodel-code-generator (PyPI): affected from 0.9.1; fixed in 0.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54691/ (Markdown: https://insights.sbomify.com/CVE-2026-54691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54691
- OSV: https://osv.dev/vulnerability/CVE-2026-54691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54691/
Summaries are generated and may contain mistakes; the official description above is the record.
