# CVE-2026-54710: FreePBX: Authenticated Superfecta Arbitrary PHP Code Execution (RCE via Unsafe File Inclusion)

> Authenticated attackers can execute arbitrary PHP code on FreePBX servers via unsafe file inclusion in the Superfecta module.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-j53p-5m8r-j3p6

## What is CVE-2026-54710?

CVE-2026-54710 is a high-severity code injection vulnerability in Sangoma Freepbx, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FreePBX is an open source IP PBX. Prior to versions 16.0.40 and 17.0.7, a critical remote code execution (RCE) vulnerability exists in the superfecta module due to unsafe inclusion of arbitrary PHP files, allowing authenticated attackers to execute arbitrary PHP code on the server with the privileges of the web server user. Authentication with a known username is required. The vulnerability is rooted in the options and save_options cases in the Superfecta module's AJAX handler. The code dynamically includes PHP files from the sources/ directory based on user-supplied input. This allows an attacker to execute arbitrary code when combined with arbitrary directory creation (e.g., via the backup module) and file uploads that reveal full paths (e.g., via the soundlang module). This issue has been patched in versions 16.0.40 and 17.0.7.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-54710?

It affects 1 product.


Products: Sangoma Freepbx.

## How do I fix CVE-2026-54710?

No fix has been published for CVE-2026-54710 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54710 being exploited?

There is no known exploitation of CVE-2026-54710 in the wild and no public exploit code.

## Other vulnerabilities in Sangoma Freepbx

- [CVE-2025-57819](https://insights.sbomify.com/CVE-2025-57819/): Sangoma FreePBX Authentication Bypass (critical 10.0, exploited in the wild)
- [CVE-2019-19006](https://insights.sbomify.com/CVE-2019-19006/): Sangoma FreePBX Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2026-73663](https://insights.sbomify.com/CVE-2026-73663/): FreePBX: Unauthenticated SQL injection in FreePBX missedcall via inbound Caller ID name leads to administrator takeover (critical 9.3)
- [CVE-2026-73665](https://insights.sbomify.com/CVE-2026-73665/): FreePBX UCP: Unauthenticated remote code execution via socket.io namespace auth bypass and AMI action injection (critical 9.3)
- [CVE-2026-46376](https://insights.sbomify.com/CVE-2026-46376/): FreePBX: Unauthenticated Use of Hard-Coded Credentials Vulnerability in FreePBX UCP Interface (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54710 and fix it if it is affected.

What it is: CVE-2026-54710 is a high-severity code injection vulnerability in Sangoma Freepbx, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54710 in the wild and no public exploit code.

Affected product: Sangoma Freepbx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54710/ (Markdown: https://insights.sbomify.com/CVE-2026-54710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54710
- OSV: https://osv.dev/vulnerability/CVE-2026-54710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54710/
Summaries are generated and may contain mistakes; the official description above is the record.
