# CVE-2026-54711: PGHoard: Password written to debug log


- **Severity:** Low 2.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-mpx4-jmpr-vm8v, PYSEC-2026-2872

## What is CVE-2026-54711?

CVE-2026-54711 is a low-severity vulnerability in Aiven-Open pghoard, published on 23 Oct 2026. 

### Official description

pghoard is a PostgreSQL backup daemon and restore tooling that stores backup data in cloud object stores. Prior to version 2.7.1, when using .pgpass, database connection information including the username and password will be logged at the debug level. This issue has been patched in version 2.7.1.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-54711?

3 open source packages ship an affected version, including pghoard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pghoard` | PyPI | All versions to 2.1.0 | None |
| `pghoard` | PyPI | All versions to 2.1.0 | None |
| `pghoard` | PyPI | All versions to 2.1.0 | None |

## How do I fix CVE-2026-54711?

No fix has been published for CVE-2026-54711 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54711 being exploited?

There is no known exploitation of CVE-2026-54711 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54711 and fix it if it is affected.

What it is: CVE-2026-54711 is a low-severity vulnerability in Aiven-Open pghoard, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-54711 in the wild and no public exploit code.

Affected packages and fixed versions:
- pghoard (PyPI): affected all versions up to 2.1.0; no fix listed
- pghoard (PyPI): affected all versions up to 2.1.0; no fix listed
- pghoard (PyPI): affected all versions up to 2.1.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54711/ (Markdown: https://insights.sbomify.com/CVE-2026-54711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54711
- OSV: https://osv.dev/vulnerability/CVE-2026-54711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54711/
Summaries are generated and may contain mistakes; the official description above is the record.
