# CVE-2026-54712: OpenTelemetry Javaagent RMI context propagation allows resource exhaustion

> Attackers can cause denial of service via oversized RMI payloads in OpenTelemetry Java Instrumentation when RMI instrumentation is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** GHSA-fq3f-m5qm-99f5

## What is CVE-2026-54712?

CVE-2026-54712 is a medium-severity denial of service vulnerability in open-telemetry opentelemetry-java-instrumentation, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenTelemetry Java Instrumentation provides OpenTelemetry auto-instrumentation and instrumentation libraries for Java. In versions prior to 2.27.0, the RMI context propagation payload reader limits the number of context entries but does not limit the aggregate size of the strings read from the stream. An attacker who can reach an RMI endpoint on an instrumented JVM can send an oversized context propagation payload. This can cause excessive memory allocation while the JVM reads the payload, potentially leading to denial of service. The issue affects only deployments where RMI instrumentation is enabled and an RMI endpoint is network-reachable. This issue has been fixed in version 2.27.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-54712?

2 open source packages ship an affected version, including io.opentelemetry.javaagent:opentelemetry-javaagent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.opentelemetry.javaagent:opentelemetry-javaagent` | Maven | All versions | 2.27.0 |
| `io.opentelemetry.javaagent:opentelemetry-javaagent` | Maven | All versions | 2.27.0 |

Products: Linuxfoundation Opentelemetry Instrumentation for Java.

## How do I fix CVE-2026-54712?

Upgrade io.opentelemetry.javaagent:opentelemetry-javaagent to 2.27.0 or later.

## Is CVE-2026-54712 being exploited?

There is no known exploitation of CVE-2026-54712 in the wild and no public exploit code.

## Other vulnerabilities in open-telemetry opentelemetry-java-instrumentation

- [CVE-2026-33701](https://insights.sbomify.com/CVE-2026-33701/): OpenTelemetry: Unsafe Deserialization in RMI Instrumentation may Lead to Remote Code Execution (critical 9.3)
- [CVE-2026-54704](https://insights.sbomify.com/CVE-2026-54704/): OpenTelemetry Java Instrumentation: JDBC Auto-Instrumentation Logging Clear-Text Passwords (medium 6.5)
- [CVE-2023-39951](https://insights.sbomify.com/CVE-2023-39951/): Information disclosure in opentelemetry-java-instrumentation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54712 and fix it if it is affected.

What it is: CVE-2026-54712 is a medium-severity denial of service vulnerability in open-telemetry opentelemetry-java-instrumentation, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54712 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.opentelemetry.javaagent:opentelemetry-javaagent (Maven): affected all versions; fixed in 2.27.0
- io.opentelemetry.javaagent:opentelemetry-javaagent (Maven): affected all versions; fixed in 2.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54712/ (Markdown: https://insights.sbomify.com/CVE-2026-54712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54712
- OSV: https://osv.dev/vulnerability/CVE-2026-54712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54712/
Summaries are generated and may contain mistakes; the official description above is the record.
