# CVE-2026-54713: CakePHP Queue: Incomplete Comparison in getUniqueId vulnerable to collisions

> An attacker can cause legitimate jobs to be dropped as duplicates by exploiting identifier collisions in the CakePHP Queue library when unique job enforcement is enabled.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-r5pm-vrc5-3m73

## What is CVE-2026-54713?

CVE-2026-54713 is a low-severity vulnerability in cakephp queue, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CakePHP Queue is a queue-interop compatible queueing library. From 0.1.11 until 2.3.1, QueueManager::getUniqueId() generates identifiers for jobs with shouldBeUnique enabled from the job class, method, and parameters, but sorting parameter values drops associative-array keys. An unauthenticated attacker who can influence job parameters can submit semantically different data that produces the same identifier, resulting in legitimate jobs dropped as duplicate collisions. This issue is fixed in version 2.3.1.

Weakness: CWE-1023 (Incomplete Comparison with Missing Factors)

## Which versions are affected by CVE-2026-54713?

2 open source packages ship an affected version, including cakephp/queue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/queue` | Packagist | From 0.1.10 | 2.3.1 |
| `cakephp/queue` | Packagist | From 0.1.10 | 2.3.1 |

## How do I fix CVE-2026-54713?

Upgrade cakephp/queue to 2.3.1 or later.

## Is CVE-2026-54713 being exploited?

There is no known exploitation of CVE-2026-54713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54713 and fix it if it is affected.

What it is: CVE-2026-54713 is a low-severity vulnerability in cakephp queue, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54713 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/queue (Packagist): affected from 0.1.10; fixed in 2.3.1
- cakephp/queue (Packagist): affected from 0.1.10; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54713/ (Markdown: https://insights.sbomify.com/CVE-2026-54713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54713
- OSV: https://osv.dev/vulnerability/CVE-2026-54713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54713/
Summaries are generated and may contain mistakes; the official description above is the record.
