CVE-2026-54718 Silverstripe Advanced Workflow: Remote code execution via advanced workflow email template
An attacker with template authoring permissions can inject server-side code into workflow email templates, leading to arbitrary code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54718?
CVE-2026-54718 is a high-severity code injection vulnerability in silverstripe-advancedworkflow, published on 27 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Silverstripe Advanced Workflow is a highly configurable step-based workflow module. Prior to 6.4.5, 7.1.3, and 7.2.1, an attacker with permission to author the advanced workflow email template can place a specially crafted server-side template payload in NotifyUsersWorkflowAction.EmailTemplate. When NotifyUsersWorkflowAction renders the field through the Silverstripe template engine SSTemplateParser, the payload can cause PHP evaluation and arbitrary code execution on the server; the regression coverage is in tests/php/WorkflowEngineTest.php. This issue is fixed in versions 6.4.5, 7.1.3, and 7.2.1.
Weakness: CWE-1336
Which versions are affected by CVE-2026-54718?
6 open source packages ship an affected version, including symbiote/silverstripe-advancedworkflow.
| Package | Affected | Fixed in |
|---|---|---|
symbiote/silverstripe-advancedworkflow Packagist | All versions | 6.4.5 |
symbiote/silverstripe-advancedworkflow Packagist | All versions | 6.4.5 |
symbiote/silverstripe-advancedworkflow Packagist | From 7.0.0 | 7.1.3 |
symbiote/silverstripe-advancedworkflow Packagist | From 7.0.0 | 7.1.3 |
symbiote/silverstripe-advancedworkflow Packagist | From 7.2.0 | 7.2.1 |
symbiote/silverstripe-advancedworkflow Packagist | From 7.2.0 | 7.2.1 |
How do I fix CVE-2026-54718?
Upgrade symbiote/silverstripe-advancedworkflow to a fixed version for your release line: 6.4.5, 7.1.3 or 7.2.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-54718 being exploited?
There is no known exploitation of CVE-2026-54718 in the wild and no public exploit code.
Sources
Also known as GHSA-39mm-rwm3-29jp.