# CVE-2026-54720: Silverstripe Framework: Possible XSS attack through media embed

> Attackers can execute arbitrary scripts via crafted media embeds in Silverstripe CMS, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** GHSA-gvrw-qqp5-jgc5

## What is CVE-2026-54720?

CVE-2026-54720 is a medium-severity cross-site scripting vulnerability in silverstripe-framework, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. In versions prior to 6.2.2, the "Insert media from web" functionality in the CMS is vulnerable to XSS from a specially crafted embed. This issue was fixed in version 6.2.2/

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54720?

2 open source packages ship an affected version, including silverstripe/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | All versions | 6.2.2 |
| `silverstripe/framework` | Packagist | All versions | 6.2.2 |

## How do I fix CVE-2026-54720?

Upgrade silverstripe/framework to 6.2.2 or later.

## Is CVE-2026-54720 being exploited?

There is no known exploitation of CVE-2026-54720 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54720 and fix it if it is affected.

What it is: CVE-2026-54720 is a medium-severity cross-site scripting vulnerability in silverstripe-framework, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54720 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected all versions; fixed in 6.2.2
- silverstripe/framework (Packagist): affected all versions; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54720/ (Markdown: https://insights.sbomify.com/CVE-2026-54720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54720
- OSV: https://osv.dev/vulnerability/CVE-2026-54720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54720/
Summaries are generated and may contain mistakes; the official description above is the record.
