# CVE-2026-54728: Code injection in bunkerweb

> Authenticated users can escalate privileges via improper Host header validation in BunkerWeb, potentially compromising the WAF instance.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-254j-92cv-m443

## What is CVE-2026-54728?

CVE-2026-54728 is a medium-severity code injection vulnerability in bunkerity bunkerweb, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

bunkerweb is an Open-source and next-generation Web Application Firewall (WAF). Prior to BunkerWeb 1.6.12 and BunkerWeb PRO 0.57, authenticated Host header handling in the BunkerWeb UI and API improperly validated and neutralized user-controlled input in a configuration-dependent path, allowing a low-privileged authenticated user to escalate privileges and affect confidentiality, integrity, and availability of the BunkerWeb instance. This issue is fixed in BunkerWeb version 1.6.12 and BunkerWeb PRO version 0.57.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-54728?


## How do I fix CVE-2026-54728?

No fix has been published for CVE-2026-54728 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54728 being exploited?

There is no known exploitation of CVE-2026-54728 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54728 and fix it if it is affected.

What it is: CVE-2026-54728 is a medium-severity code injection vulnerability in bunkerity bunkerweb, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54728 in the wild and no public exploit code.

Affected product: bunkerity bunkerweb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54728/ (Markdown: https://insights.sbomify.com/CVE-2026-54728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54728
- OSV: https://osv.dev/vulnerability/CVE-2026-54728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54728/
Summaries are generated and may contain mistakes; the official description above is the record.
