# CVE-2026-54729: dssrf: any users using 1.1.1.1 DNS is impacted by SSRF

> An SSRF vulnerability in the dssrf library allows bypassing localhost protections when using Cloudflare DNS, potentially exposing internal services.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-5846-7qm3-r52j

## What is CVE-2026-54729?

CVE-2026-54729 is a high-severity server-side request forgery vulnerability in HackingRepo dssrf-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DSSRF is a Node.js library that provides a wide range of utilities and advanced SSRF defense checks. Prior to 1.0.5, is_url_safe can treat localhost as safe when DNS resolver 1.1.1.1 returns NXDOMAIN because dns.resolve4 yields no address and no dns.lookup fallback occurs, allowing server-side request forgery. This issue is fixed in version 1.0.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54729?

2 open source packages ship an affected version, including dssrf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dssrf` | npm | All versions | 1.0.5 |
| `dssrf` | npm | All versions | 1.0.5 |

## How do I fix CVE-2026-54729?

Upgrade dssrf to 1.0.5 or later.

## Is CVE-2026-54729 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54729 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54729 and fix it if it is affected.

What it is: CVE-2026-54729 is a high-severity server-side request forgery vulnerability in HackingRepo dssrf-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54729 exists.

Affected packages and fixed versions:
- dssrf (npm): affected all versions; fixed in 1.0.5
- dssrf (npm): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54729/ (Markdown: https://insights.sbomify.com/CVE-2026-54729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54729
- OSV: https://osv.dev/vulnerability/CVE-2026-54729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54729/
Summaries are generated and may contain mistakes; the official description above is the record.
