# CVE-2026-54735: prebid-server's request forgery vulnerability allows for possible host environment data extraction

> Attackers can exploit improper URL validation in bidder adapters to perform server-side request forgery, potentially exposing internal network services or sensitive endpoints.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-4p3g-4hcj-wpvx, GO-2026-6139

## What is CVE-2026-54735?

CVE-2026-54735 is a critical server-side request forgery vulnerability in prebid-server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prebid Server is an open-source solution for running real-time advertising auctions in the cloud. Prior to version 4.4.0, certain bidder adapters in Prebid Server interpolate user-supplied parameters into outbound request URLs without properly validating host and subdomain values, allowing crafted bid request parameters to cause server-side requests to unintended destinations and potentially expose internal network services or sensitive server endpoints. This issue is fixed in version 4.4.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54735?

9 open source packages ship an affected version, including github.com/prebid/prebid-server/v4, github.com/prebid/prebid-server and github.com/prebid/prebid-server/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/prebid/prebid-server/v4` | Go | All versions | 4.4.0 |
| `github.com/prebid/prebid-server/v4` | Go | All versions | 4.4.0 |
| `github.com/prebid/prebid-server/v4` | Go | All versions | 4.4.0 |
| `github.com/prebid/prebid-server` | Go | All versions to 0.275.0 | None |
| `github.com/prebid/prebid-server` | Go | All versions to 0.275.0 | None |
| `github.com/prebid/prebid-server/v2` | Go | All versions to 2.32.0 | None |
| `github.com/prebid/prebid-server/v2` | Go | All versions to 2.32.0 | None |
| `github.com/prebid/prebid-server/v3` | Go | All versions to 3.30.0 | None |
| `github.com/prebid/prebid-server/v3` | Go | All versions to 3.30.0 | None |

Products: Prebid Prebid Server.

## How do I fix CVE-2026-54735?

Upgrade github.com/prebid/prebid-server/v4 to 4.4.0 or later.

## Is CVE-2026-54735 being exploited?

There is no known exploitation of CVE-2026-54735 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54735 and fix it if it is affected.

What it is: CVE-2026-54735 is a critical server-side request forgery vulnerability in prebid-server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54735 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/prebid/prebid-server/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/prebid/prebid-server/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/prebid/prebid-server/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/prebid/prebid-server (Go): affected all versions up to 0.275.0; no fix listed
- github.com/prebid/prebid-server (Go): affected all versions up to 0.275.0; no fix listed
- github.com/prebid/prebid-server/v2 (Go): affected all versions up to 2.32.0; no fix listed
- github.com/prebid/prebid-server/v2 (Go): affected all versions up to 2.32.0; no fix listed
- github.com/prebid/prebid-server/v3 (Go): affected all versions up to 3.30.0; no fix listed
- github.com/prebid/prebid-server/v3 (Go): affected all versions up to 3.30.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54735/ (Markdown: https://insights.sbomify.com/CVE-2026-54735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54735
- OSV: https://osv.dev/vulnerability/CVE-2026-54735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54735/
Summaries are generated and may contain mistakes; the official description above is the record.
