# CVE-2026-54737: @phun-ky/defaults-deep Has a Prototype Pollution issue via Unsafe Recursive Property Merging

> Prototype pollution in defaults-deep allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-mj3g-7xcc-x4vh

## What is CVE-2026-54737?

CVE-2026-54737 is a high-severity vulnerability in phun-ky defaults-deep, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@phun-ky/defaults-deep is a library like lodash defaultsDeep with array preservation and no lodash dependency. Prior to 2.0.5, defaultsDeep() recursively merges user-supplied objects without filtering proto, constructor, and prototype, allowing properties to be written to Object.prototype. This issue is fixed in version 2.0.5.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-54737?

2 open source packages ship an affected version, including @phun-ky/defaults-deep.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@phun-ky/defaults-deep` | npm | All versions | 2.0.5 |
| `@phun-ky/defaults-deep` | npm | All versions | 2.0.5 |

## How do I fix CVE-2026-54737?

Upgrade @phun-ky/defaults-deep to 2.0.5 or later.

## Is CVE-2026-54737 being exploited?

There is no known exploitation of CVE-2026-54737 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54737 and fix it if it is affected.

What it is: CVE-2026-54737 is a high-severity vulnerability in phun-ky defaults-deep, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54737 in the wild and no public exploit code.

Affected packages and fixed versions:
- @phun-ky/defaults-deep (npm): affected all versions; fixed in 2.0.5
- @phun-ky/defaults-deep (npm): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54737/ (Markdown: https://insights.sbomify.com/CVE-2026-54737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54737
- OSV: https://osv.dev/vulnerability/CVE-2026-54737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54737/
Summaries are generated and may contain mistakes; the official description above is the record.
