# CVE-2026-54739: Lemmy: Login Endpoint User Enumeration via HTTP Response Code Differential

> An unauthenticated attacker can enumerate registered usernames or emails by observing HTTP response code differences on the login endpoint.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-xgg7-8hvq-8m65

## What is CVE-2026-54739?

CVE-2026-54739 is a medium-severity vulnerability in LemmyNet lemmy, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lemmy is a link aggregator and forum for the fediverse. Prior to 0.19.19 and 1.0.0-beta.1, Lemmy's login endpoint in crates/api/api/src/local_user/login.rs returns different errors depending on whether the username_or_email value exists. LocalUserView::find_by_email_or_name propagates a NotFound response for an unknown account, while an existing account with a wrong password returns LemmyErrorType::IncorrectLogin. This observable response discrepancy, including HTTP 404 for a nonexistent account and HTTP 400 for an incorrect password on an existing account, allows an unauthenticated attacker to confirm registered usernames or email addresses and use the results for targeted credential attacks or social engineering. This issue is fixed in versions 0.19.19 and 1.0.0-beta.1.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2026-54739?


## How do I fix CVE-2026-54739?

No fix has been published for CVE-2026-54739 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54739 being exploited?

There is no known exploitation of CVE-2026-54739 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54739 and fix it if it is affected.

What it is: CVE-2026-54739 is a medium-severity vulnerability in LemmyNet lemmy, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54739 in the wild and no public exploit code.

Affected product: LemmyNet lemmy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54739/ (Markdown: https://insights.sbomify.com/CVE-2026-54739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54739
- OSV: https://osv.dev/vulnerability/CVE-2026-54739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54739/
Summaries are generated and may contain mistakes; the official description above is the record.
