{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54741 exists.","fix":"No fix has been published for CVE-2026-54741 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-54741 is a medium-severity missing authorization vulnerability in LemmyNet lemmy, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54741 and fix it if it is affected.\n\nWhat it is: CVE-2026-54741 is a medium-severity missing authorization vulnerability in LemmyNet lemmy, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54741 exists.\n\nAffected product: LemmyNet lemmy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54741/ (Markdown: https://insights.sbomify.com/CVE-2026-54741/index.md)","id":"CVE-2026-54741","markdown":"https://insights.sbomify.com/CVE-2026-54741/index.md","name":"CVE-2026-54741","record":{"aliases":["GHSA-46g9-847m-qf8r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fediverse link aggregator","requires_auth":"low_privilege","summary":"Blocked users can edit previously sent private messages because the edit function fails to verify the recipient's block list, enabling post-block harassment.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Lemmy is a link aggregator and forum for the fediverse. Prior to 0.19.19 and 1.0.0-alpha.18, Lemmy blocks new private messages from a sender after the recipient blocks that sender, but the edit path skips the same block check. create_private_message checks the recipient's block list with PersonActions::read_block before inserting a message, while edit_private_message in crates/api/api_crud/src/private_message/update.rs only checks that the caller is orig_private_message.creator_id. The update then writes new content and returns the modified PrivateMessageView without consulting the recipient's block list, allowing a blocked sender to keep changing an old message that the recipient can still see and providing a post-block harassment path. This issue is fixed in versions 0.19.19 and 1.0.0-alpha.18.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Lemmy: Blocked users can edit private messages sent before the block","id":"CVE-2026-54741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"Lemmy: `CollectionAdd::Featured` does not check the post is in the community","id":"CVE-2026-54742"},"packages":[],"prev":{"headline":"Lemmy: Lower-ranked federated moderator can remove higher-ranked moderators","id":"CVE-2026-54740"},"products":["lemmy"],"published":"2026-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["LemmyNet"]},"summary":"Blocked users can edit previously sent private messages because the edit function fails to verify the recipient's block list, enabling post-block harassment.","url":"https://insights.sbomify.com/CVE-2026-54741/"}