# CVE-2026-54741: Lemmy: Blocked users can edit private messages sent before the block

> Blocked users can edit previously sent private messages because the edit function fails to verify the recipient's block list, enabling post-block harassment.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-46g9-847m-qf8r

## What is CVE-2026-54741?

CVE-2026-54741 is a medium-severity missing authorization vulnerability in LemmyNet lemmy, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemmy is a link aggregator and forum for the fediverse. Prior to 0.19.19 and 1.0.0-alpha.18, Lemmy blocks new private messages from a sender after the recipient blocks that sender, but the edit path skips the same block check. create_private_message checks the recipient's block list with PersonActions::read_block before inserting a message, while edit_private_message in crates/api/api_crud/src/private_message/update.rs only checks that the caller is orig_private_message.creator_id. The update then writes new content and returns the modified PrivateMessageView without consulting the recipient's block list, allowing a blocked sender to keep changing an old message that the recipient can still see and providing a post-block harassment path. This issue is fixed in versions 0.19.19 and 1.0.0-alpha.18.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-54741?


## How do I fix CVE-2026-54741?

No fix has been published for CVE-2026-54741 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54741 and fix it if it is affected.

What it is: CVE-2026-54741 is a medium-severity missing authorization vulnerability in LemmyNet lemmy, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54741 exists.

Affected product: LemmyNet lemmy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54741/ (Markdown: https://insights.sbomify.com/CVE-2026-54741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54741
- OSV: https://osv.dev/vulnerability/CVE-2026-54741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54741/
Summaries are generated and may contain mistakes; the official description above is the record.
