{"answers":{"affected":"3 open source packages ship an affected version, including langroid.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54760 exists.","fix":"Upgrade langroid to 0.65.1 or later.","what":"CVE-2026-54760 is a critical SQL injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54760 and fix it if it is affected.\n\nWhat it is: CVE-2026-54760 is a critical SQL injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54760 exists.\n\nAffected packages and fixed versions:\n- langroid (PyPI): affected all versions; fixed in 0.65.1\n- langroid (PyPI): affected all versions; fixed in 0.65.1\n- langroid (PyPI): affected all versions; fixed in 0.65.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54760/ (Markdown: https://insights.sbomify.com/CVE-2026-54760/index.md)","id":"CVE-2026-54760","markdown":"https://insights.sbomify.com/CVE-2026-54760/index.md","name":"CVE-2026-54760","record":{"aliases":["GHSA-6xc5-4r68-67fc","PYSEC-2026-2577"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Langroid LLM framework","requires_auth":"none","summary":"Attackers can bypass SQL injection protections in Langroid's SQLChatAgent to read arbitrary server files via crafted PostgreSQL queries.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Langroid is a framework for building large-language-model-powered applications. Prior to version 0.65.1, the `SQLChatAgent` SQL-injection mitigation, with default `allow_dangerous_operations=False`, combines a raw-text regex blocklist (`_DANGEROUS_SQL_PATTERNS`) with a `sqlglot` SELECT-only statement allowlist. The blocklist entries that target callable functions require the function name to be immediately followed by `\\s*\\(`. PostgreSQL accepts the same call with the name separated from `(` by a quoted identifier, an inline comment, or schema qualification. These forms evade the regex, still parse as `SELECT`, and execute the same PostgreSQL function. This restores the `pg_read_file` server-side file-read primitive that the prior CVE-2026-25879 / GHSA-pmch-g965-grmr fix was meant to block: the parent advisory fixed a missing `pg_read_file` blocklist entry, while this report shows that the added regex is bypassable. Version 0.65.1 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Langroid: SQLChatAgent dangerous-function blocklist can be bypassed with quoted or schema-qualified pg_read_file calls","id":"CVE-2026-54760","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Traefik: Kubernetes Gateway crossProviderNamespaces bypass allows HTTPRoute outside the allowlist to expose internal Traefik services","id":"CVE-2026-54761"},"packages":[{"ecosystem":"PyPI","fixed":["0.65.1"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":null,"source":"GHSA-6xc5-4r68-67fc"},{"ecosystem":"PyPI","fixed":["0.65.1"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"GHSA-6xc5-4r68-67fc"},{"ecosystem":"PyPI","fixed":["0.65.1"],"introduced":["0"],"last_affected":[],"package":"langroid","purl":"pkg:pypi/langroid","source":"PYSEC-2026-2577"}],"prev":{"headline":"Cross-site scripting in siyuan","id":"CVE-2026-54759"},"products":["langroid"],"published":"2026-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["langroid"]},"summary":"Attackers can bypass SQL injection protections in Langroid's SQLChatAgent to read arbitrary server files via crafted PostgreSQL queries.","url":"https://insights.sbomify.com/CVE-2026-54760/"}