# CVE-2026-54760: Langroid: SQLChatAgent dangerous-function blocklist can be bypassed with quoted or schema-qualified pg_read_file calls

> Attackers can bypass SQL injection protections in Langroid's SQLChatAgent to read arbitrary server files via crafted PostgreSQL queries.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-6xc5-4r68-67fc, PYSEC-2026-2577

## What is CVE-2026-54760?

CVE-2026-54760 is a critical SQL injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Langroid is a framework for building large-language-model-powered applications. Prior to version 0.65.1, the `SQLChatAgent` SQL-injection mitigation, with default `allow_dangerous_operations=False`, combines a raw-text regex blocklist (`_DANGEROUS_SQL_PATTERNS`) with a `sqlglot` SELECT-only statement allowlist. The blocklist entries that target callable functions require the function name to be immediately followed by `\s*\(`. PostgreSQL accepts the same call with the name separated from `(` by a quoted identifier, an inline comment, or schema qualification. These forms evade the regex, still parse as `SELECT`, and execute the same PostgreSQL function. This restores the `pg_read_file` server-side file-read primitive that the prior CVE-2026-25879 / GHSA-pmch-g965-grmr fix was meant to block: the parent advisory fixed a missing `pg_read_file` blocklist entry, while this report shows that the added regex is bypassable. Version 0.65.1 fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54760?

3 open source packages ship an affected version, including langroid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langroid` | PyPI | All versions | 0.65.1 |
| `langroid` | PyPI | All versions | 0.65.1 |
| `langroid` | PyPI | All versions | 0.65.1 |

## How do I fix CVE-2026-54760?

Upgrade langroid to 0.65.1 or later.

## Is CVE-2026-54760 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54760 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54760 and fix it if it is affected.

What it is: CVE-2026-54760 is a critical SQL injection vulnerability in langroid, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54760 exists.

Affected packages and fixed versions:
- langroid (PyPI): affected all versions; fixed in 0.65.1
- langroid (PyPI): affected all versions; fixed in 0.65.1
- langroid (PyPI): affected all versions; fixed in 0.65.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54760/ (Markdown: https://insights.sbomify.com/CVE-2026-54760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54760
- OSV: https://osv.dev/vulnerability/CVE-2026-54760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54760/
Summaries are generated and may contain mistakes; the official description above is the record.
