# CVE-2026-54768: WPGraphQL has deprecated `user` field on SendPasswordResetEmailPayload that leaks user existence + profile (defeats explicit anti-enumeration design)

> Unauthenticated attackers can enumerate existing author accounts and retrieve public profile data via the password reset mutation, bypassing anti-enumeration controls.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Jul 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-jhh7-832h-f8hv

## What is CVE-2026-54768?

CVE-2026-54768 is a medium-severity vulnerability in wp-graphql, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WPGraphQL provides a GraphQL API for WordPress sites. From 2.0.0 until 2.15.1, the deprecated user field on SendPasswordResetEmailPayload lets an unauthenticated caller distinguish existing author-class accounts through the sendPasswordResetEmail mutation and obtain public profile fields. This issue is fixed in version 2.15.1.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2026-54768?

2 open source packages ship an affected version, including wp-graphql/wp-graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-graphql/wp-graphql` | Packagist | All versions to 2.6.0 | None |
| `wp-graphql/wp-graphql` | Packagist | All versions to 2.6.0 | None |

## How do I fix CVE-2026-54768?

No fix has been published for CVE-2026-54768 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54768 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54768 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54768 and fix it if it is affected.

What it is: CVE-2026-54768 is a medium-severity vulnerability in wp-graphql, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54768 exists.

Affected packages and fixed versions:
- wp-graphql/wp-graphql (Packagist): affected all versions up to 2.6.0; no fix listed
- wp-graphql/wp-graphql (Packagist): affected all versions up to 2.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54768/ (Markdown: https://insights.sbomify.com/CVE-2026-54768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54768
- OSV: https://osv.dev/vulnerability/CVE-2026-54768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54768/
Summaries are generated and may contain mistakes; the official description above is the record.
