# CVE-2026-54771: Langroid: handle_message() executes user-supplied tool JSON without sender verification

> Attackers can execute arbitrary tools via raw JSON payloads in Langroid chat interfaces, bypassing sender verification controls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-gjgq-w2m6-wr5q, PYSEC-2026-2579

## What is CVE-2026-54771?

CVE-2026-54771 is a high-severity code injection vulnerability in langroid, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langroid is a framework for building large-language-model-powered applications. Prior to version 0.65.3, a Langroid application exposing a chat interface to untrusted users may allow direct tool invocation via raw JSON payloads, even when tools are registered with `use=False, handle=True`. Version 0.65.3 fixes the issue.

Weakness: CWE-75 (Failure to Sanitize Special Elements into a Different Plane)

## Which versions are affected by CVE-2026-54771?

3 open source packages ship an affected version, including langroid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langroid` | PyPI | All versions | 0.65.3 |
| `langroid` | PyPI | All versions | 0.65.3 |
| `langroid` | PyPI | All versions | 0.65.3 |

## How do I fix CVE-2026-54771?

Upgrade langroid to 0.65.3 or later.

## Is CVE-2026-54771 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54771 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54771 and fix it if it is affected.

What it is: CVE-2026-54771 is a high-severity code injection vulnerability in langroid, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54771 exists.

Affected packages and fixed versions:
- langroid (PyPI): affected all versions; fixed in 0.65.3
- langroid (PyPI): affected all versions; fixed in 0.65.3
- langroid (PyPI): affected all versions; fixed in 0.65.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54771/ (Markdown: https://insights.sbomify.com/CVE-2026-54771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54771
- OSV: https://osv.dev/vulnerability/CVE-2026-54771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54771/
Summaries are generated and may contain mistakes; the official description above is the record.
