# CVE-2026-54785: gemini-bridge vulnerable to arbitrary local file read via consult_gemini_with_files inline mode

> An attacker can read arbitrary local files by supplying malicious paths to the consult_gemini_with_files function, exposing sensitive data.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-c5px-58j2-7fqp, PYSEC-2026-3574

## What is CVE-2026-54785?

CVE-2026-54785 is a medium-severity path traversal vulnerability in eLyiN gemini-bridge, published on 31 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

gemini-bridge is a lightweight MCP server bridging AI agents to Google's Gemini AI via the official CLI. From 1.0.0 until 1.3.1, consult_gemini_with_files in inline mode read any file path supplied in the files argument without confining it to the working directory, then forwarded the contents to the Gemini CLI. Because the caller also controls query, the file contents are echoed back through the Gemini round-trip (and sent to Google), making this an arbitrary local file read. This issue is fixed in version 1.3.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54785?

3 open source packages ship an affected version, including gemini-bridge.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gemini-bridge` | PyPI | From 1.0.0 | 1.3.1 |
| `gemini-bridge` | PyPI | From 1.0.0 | 1.3.1 |
| `gemini-bridge` | PyPI | From 1.0.0 | 1.3.1 |

## How do I fix CVE-2026-54785?

Upgrade gemini-bridge to 1.3.1 or later.

## Is CVE-2026-54785 being exploited?

There is no known exploitation of CVE-2026-54785 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54785 and fix it if it is affected.

What it is: CVE-2026-54785 is a medium-severity path traversal vulnerability in eLyiN gemini-bridge, published on 31 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54785 in the wild and no public exploit code.

Affected packages and fixed versions:
- gemini-bridge (PyPI): affected from 1.0.0; fixed in 1.3.1
- gemini-bridge (PyPI): affected from 1.0.0; fixed in 1.3.1
- gemini-bridge (PyPI): affected from 1.0.0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54785/ (Markdown: https://insights.sbomify.com/CVE-2026-54785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54785
- OSV: https://osv.dev/vulnerability/CVE-2026-54785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54785/
Summaries are generated and may contain mistakes; the official description above is the record.
