CVE-2026-54892 Plug: quadratic-time decoding of nested query/body parameters enables denial of service
Unauthenticated attackers can cause denial of service in Plug-based servers by sending deeply nested query parameters that trigger quadratic-time decoding.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54892?
CVE-2026-54892 is a high-severity denial of service vulnerability in elixir-plug plug, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Inefficient algorithmic complexity in Plug's nested-parameter decoder allows an unauthenticated remote attacker to cause denial of service. Plug.Conn.Query.decode/4 (and Plug.Conn.Query.decode_each/2) parse query strings and application/x-www-form-urlencoded request bodies. When a key contains many bracketed segments such as a[a][a][a]=1, the decoder walks the brackets and, for each of the N levels, performs a map operation keyed on an ever-growing binary prefix of the key, hashing the full byte range at each step. The total decode cost is therefore quadratic in the number of nesting levels.
With the default Plug.Parsers.URLENCODED body limit of 1,000,000 bytes, a single request can carry roughly 333,000 nesting levels and saturate a BEAM scheduler for minutes. A small number of concurrent requests can saturate all schedulers and render a Plug-based server unresponsive. No authentication or knowledge of application routes is required.
This vulnerability is associated with program files lib/plug/conn/query.ex and program routines Plug.Conn.Query.decode/4, Plug.Conn.Query.decode_each/2, Plug.Conn.Query.split_keys/6, Plug.Conn.Query.insert_keys/3, and Plug.Conn.Query.finalize_pointer/2.
This issue affects plug from 1.15.0 before 1.15.5, 1.16.4, 1.17.2, 1.18.3, and 1.19.3.
Weakness: CWE-407
Which versions are affected by CVE-2026-54892?
11 open source packages ship an affected version, including plug.
| Package | Affected | Fixed in |
|---|---|---|
plug Hex | From 1.15.0 | 1.15.5, 1.16.4, 1.17.2, 1.18.3, 1.19.3 |
plug Hex | From 1.15.0 | 1.15.5 |
plug Hex | From 1.15.0 | 1.15.5 |
plug Hex | From 1.16.0 | 1.16.4 |
plug Hex | From 1.16.0 | 1.16.4 |
plug Hex | From 1.17.0 | 1.17.2 |
5 more packages
plug Hex | From 1.17.0 | 1.17.2 |
plug Hex | From 1.18.0 | 1.18.3 |
plug Hex | From 1.18.0 | 1.18.3 |
plug Hex | From 1.19.0 | 1.19.3 |
plug Hex | From 1.19.0 | 1.19.3 |
How do I fix CVE-2026-54892?
Upgrade plug to a fixed version for your release line: 1.15.5, 1.16.4, 1.17.2 or 1.18.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-54892 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54892 exists.
Sources
Also known as EEF-CVE-2026-54892, GHSA-j43x-5hjq-rgxf.