# CVE-2026-54897: Oj : Use-After-Free in Oj::Doc Iterators via Reentrant Close

> A use-after-free vulnerability in Oj::Doc iterators allows attackers to trigger memory corruption and potential code execution via reentrant close calls.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 1 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-54897, GHSA-9ppp-w3g4-fh4q, MINI-2xpc-mfgp-7w59, MINI-747w-rw27-8mrf, MINI-95p6-v5pf-v8jr, MINI-9c8m-j5vv-96m4, MINI-ccmx-wr9f-3234, MINI-g9x2-c54q-gx4j, MINI-hfvm-7pvw-369c, MINI-jx8x-76rc-6xm4, MINI-v9qg-v9rr-xx9x, MINI-w27w-gmf4-3qrv, UBUNTU-CVE-2026-54897

## What is CVE-2026-54897?

CVE-2026-54897 is a low-severity use after free vulnerability in ohler55 oj, published on 30 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Oj (Optimized JSON) is a JSON parser and Object marshaller packaged as a Ruby gem. Prior to 3.17.2, Oj::Doc iterators (each_value, each_child, each_leaf) were vulnerable to a heap use-after-free. When a Ruby block yielded during iteration calls doc.close or d.close, the document's heap memory is freed while the C iterator is still running. When control returns from the block, the iterator reads from the freed region, producing a use-after-free accessible from pure Ruby. This issue has been fixed in version 3.17.2.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-54897?

2 open source packages ship an affected version, including oj.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oj` | RubyGems | All versions | 3.17.3 |
| `oj` | RubyGems | All versions | 3.17.3 |

## How do I fix CVE-2026-54897?

Upgrade oj to 3.17.3 or later.

## Is CVE-2026-54897 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54897 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54897 and fix it if it is affected.

What it is: CVE-2026-54897 is a low-severity use after free vulnerability in ohler55 oj, published on 30 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54897 exists.

Affected packages and fixed versions:
- oj (RubyGems): affected all versions; fixed in 3.17.3
- oj (RubyGems): affected all versions; fixed in 3.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54897/ (Markdown: https://insights.sbomify.com/CVE-2026-54897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54897
- OSV: https://osv.dev/vulnerability/CVE-2026-54897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54897/
Summaries are generated and may contain mistakes; the official description above is the record.
