{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-54907 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-54907 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-54907 is a medium-severity vulnerability in fuomag9 caddy-proxy-manager, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54907 and fix it if it is affected.\n\nWhat it is: CVE-2026-54907 is a medium-severity vulnerability in fuomag9 caddy-proxy-manager, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54907 in the wild and no public exploit code.\n\nAffected product: fuomag9 caddy-proxy-manager. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54907/ (Markdown: https://insights.sbomify.com/CVE-2026-54907/index.md)","id":"CVE-2026-54907","markdown":"https://insights.sbomify.com/CVE-2026-54907/index.md","name":"CVE-2026-54907","record":{"aliases":["GHSA-4wcc-gwxr-gc9p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Caddy Proxy Manager","requires_auth":"none","summary":"Unauthenticated attackers can create low-privilege user accounts due to default self-registration settings in Caddy Proxy Manager.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"}],"description":"Caddy Proxy Manager is a web interface for managing Caddy Server reverse proxies and certificates. Prior to 1.5.1, Caddy Proxy Manager enables email and password self-registration by default at /api/auth/sign-up/email, allowing an unauthenticated remote actor to create an active account with the user role without administrator approval. The user role cannot view or modify proxy data, so the direct impact is limited to unauthorized creation of low-privilege accounts. The fixed configuration in src/lib/config.ts and src/lib/auth-server.ts requires AUTH_ALLOW_SELF_REGISTRATION=true before the authentication library's disableSignUp control permits sign-up. This issue is fixed in version 1.5.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Caddy Proxy Manager: Registrations enabled by default allows creating users with \"user\" permission","id":"CVE-2026-54907","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Pion DTLS: Denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message","id":"CVE-2026-54908"},"packages":[],"prev":{"headline":"concurrent-ruby: ReadWriteLock allows wrong-thread write release and stray read-release counter corruption","id":"CVE-2026-54906"},"products":["caddy-proxy-manager"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["fuomag9"]},"summary":"Unauthenticated attackers can create low-privilege user accounts due to default self-registration settings in Caddy Proxy Manager.","url":"https://insights.sbomify.com/CVE-2026-54907/"}