# CVE-2026-54907: Caddy Proxy Manager: Registrations enabled by default allows creating users with "user" permission

> Unauthenticated attackers can create low-privilege user accounts due to default self-registration settings in Caddy Proxy Manager.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-4wcc-gwxr-gc9p

## What is CVE-2026-54907?

CVE-2026-54907 is a medium-severity vulnerability in fuomag9 caddy-proxy-manager, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy Proxy Manager is a web interface for managing Caddy Server reverse proxies and certificates. Prior to 1.5.1, Caddy Proxy Manager enables email and password self-registration by default at /api/auth/sign-up/email, allowing an unauthenticated remote actor to create an active account with the user role without administrator approval. The user role cannot view or modify proxy data, so the direct impact is limited to unauthorized creation of low-privilege accounts. The fixed configuration in src/lib/config.ts and src/lib/auth-server.ts requires AUTH_ALLOW_SELF_REGISTRATION=true before the authentication library's disableSignUp control permits sign-up. This issue is fixed in version 1.5.1.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-54907?


## How do I fix CVE-2026-54907?

No fix has been published for CVE-2026-54907 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54907 being exploited?

There is no known exploitation of CVE-2026-54907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54907 and fix it if it is affected.

What it is: CVE-2026-54907 is a medium-severity vulnerability in fuomag9 caddy-proxy-manager, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54907 in the wild and no public exploit code.

Affected product: fuomag9 caddy-proxy-manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54907/ (Markdown: https://insights.sbomify.com/CVE-2026-54907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54907
- OSV: https://osv.dev/vulnerability/CVE-2026-54907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54907/
Summaries are generated and may contain mistakes; the official description above is the record.
