{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pion/dtls/v3.","exploited":"There is no known exploitation of CVE-2026-54908 in the wild and no public exploit code.","fix":"Upgrade github.com/pion/dtls/v3 to 3.1.4 or later.","what":"CVE-2026-54908 is a medium-severity denial of service vulnerability in pion dtls, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54908 and fix it if it is affected.\n\nWhat it is: CVE-2026-54908 is a medium-severity denial of service vulnerability in pion dtls, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4\n- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4\n- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54908/ (Markdown: https://insights.sbomify.com/CVE-2026-54908/index.md)","id":"CVE-2026-54908","markdown":"https://insights.sbomify.com/CVE-2026-54908/index.md","name":"CVE-2026-54908","record":{"aliases":["AZL-92112","DEBIAN-CVE-2026-54908","ECHO-7afe-e0de-b808","GHSA-wg4g-wm44-ch5j","GO-2026-6165","MINI-23cg-qqhp-2j3f","MINI-2mjh-497v-fcq4","MINI-2qqx-mr46-ccpv","MINI-34rw-wcw8-j7mh","MINI-3jv8-6cgq-wcqf","MINI-44j5-wv2c-59ff","MINI-5cfv-q2r2-994f","MINI-9v8r-jh84-x5hc","MINI-cpgh-wjjp-8x3r","MINI-cvvp-3jr7-28j5","MINI-f68f-f8c8-xcpw","MINI-f9v6-pj3v-5fmf","MINI-gcwf-2c6q-pjf5","MINI-h6pm-3pv4-vjg7","MINI-h83f-p7rf-jp7g","MINI-h8hq-fv2m-hr2h","MINI-m9pw-hwpm-gcfj","MINI-mgw8-hpwh-vh7f","MINI-pgrq-c7jr-pvcv","MINI-pv34-mpc2-6fx2","MINI-pxh7-7gxh-9wjp","MINI-q8wp-4vh4-f5c8","MINI-qp9x-5xv3-5q53","MINI-r29m-9cm5-rwww","MINI-v4j4-h56f-7q6h","MINI-xp6w-gp4p-7wfq","UBUNTU-CVE-2026-54908"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go DTLS library","requires_auth":"none","summary":"A remote attacker can cause a denial of service by sending a crafted ECDHE_PSK ServerKeyExchange message that triggers a panic in the Pion DTLS library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Pion DTLS is a Go implementation of Datagram Transport Layer Security. Versions prior to 3.1.4 are vulnerable to Remote Denial of Service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message. This issue has been fixed in version 3.1.4.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pion DTLS: Denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message","id":"CVE-2026-54908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Pion STUN vulnerable to remote denial of service via panic while parsing a malformed XOR-MAPPED-ADDRESS attribute","id":"CVE-2026-54909"},"packages":[{"ecosystem":"Go","fixed":["3.1.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v3","purl":null,"source":"GHSA-wg4g-wm44-ch5j"},{"ecosystem":"Go","fixed":["3.1.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v3","purl":"pkg:golang/github.com/pion/dtls/v3","source":"GHSA-wg4g-wm44-ch5j"},{"ecosystem":"Go","fixed":["3.1.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v3","purl":"pkg:golang/github.com/pion/dtls/v3","source":"GO-2026-6165"}],"prev":{"headline":"Caddy Proxy Manager: Registrations enabled by default allows creating users with \"user\" permission","id":"CVE-2026-54907"},"products":["dtls"],"published":"2026-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-02","vendors":["pion"]},"summary":"A remote attacker can cause a denial of service by sending a crafted ECDHE_PSK ServerKeyExchange message that triggers a panic in the Pion DTLS library.","url":"https://insights.sbomify.com/CVE-2026-54908/"}