# CVE-2026-54908: Pion DTLS: Denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message

> A remote attacker can cause a denial of service by sending a crafted ECDHE_PSK ServerKeyExchange message that triggers a panic in the Pion DTLS library.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** AZL-92112, DEBIAN-CVE-2026-54908, ECHO-7afe-e0de-b808, GHSA-wg4g-wm44-ch5j, GO-2026-6165, MINI-23cg-qqhp-2j3f, MINI-2mjh-497v-fcq4, MINI-2qqx-mr46-ccpv, MINI-34rw-wcw8-j7mh, MINI-3jv8-6cgq-wcqf, MINI-44j5-wv2c-59ff, MINI-5cfv-q2r2-994f, MINI-9v8r-jh84-x5hc, MINI-cpgh-wjjp-8x3r, MINI-cvvp-3jr7-28j5, MINI-f68f-f8c8-xcpw, MINI-f9v6-pj3v-5fmf, MINI-gcwf-2c6q-pjf5, MINI-h6pm-3pv4-vjg7, MINI-h83f-p7rf-jp7g, MINI-h8hq-fv2m-hr2h, MINI-m9pw-hwpm-gcfj, MINI-mgw8-hpwh-vh7f, MINI-pgrq-c7jr-pvcv, MINI-pv34-mpc2-6fx2, MINI-pxh7-7gxh-9wjp, MINI-q8wp-4vh4-f5c8, MINI-qp9x-5xv3-5q53, MINI-r29m-9cm5-rwww, MINI-v4j4-h56f-7q6h, MINI-xp6w-gp4p-7wfq, UBUNTU-CVE-2026-54908

## What is CVE-2026-54908?

CVE-2026-54908 is a medium-severity denial of service vulnerability in pion dtls, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pion DTLS is a Go implementation of Datagram Transport Layer Security. Versions prior to 3.1.4 are vulnerable to Remote Denial of Service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message. This issue has been fixed in version 3.1.4.

Weakness: CWE-248 (Uncaught Exception), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-54908?

3 open source packages ship an affected version, including github.com/pion/dtls/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pion/dtls/v3` | Go | All versions | 3.1.4 |
| `github.com/pion/dtls/v3` | Go | All versions | 3.1.4 |
| `github.com/pion/dtls/v3` | Go | All versions | 3.1.4 |

## How do I fix CVE-2026-54908?

Upgrade github.com/pion/dtls/v3 to 3.1.4 or later.

## Is CVE-2026-54908 being exploited?

There is no known exploitation of CVE-2026-54908 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54908 and fix it if it is affected.

What it is: CVE-2026-54908 is a medium-severity denial of service vulnerability in pion dtls, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54908 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4
- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4
- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54908/ (Markdown: https://insights.sbomify.com/CVE-2026-54908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54908
- OSV: https://osv.dev/vulnerability/CVE-2026-54908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54908/
Summaries are generated and may contain mistakes; the official description above is the record.
