{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54920 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-54920 is a denial of service vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54920 and fix it if it is affected.\n\nWhat it is: CVE-2026-54920 is a denial of service vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54920 exists.\n\nAffected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54920/ (Markdown: https://insights.sbomify.com/CVE-2026-54920/index.md)","id":"CVE-2026-54920","markdown":"https://insights.sbomify.com/CVE-2026-54920/index.md","name":"CVE-2026-54920","record":{"aliases":["AZL-97620","BELL-CVE-2026-54920","DEBIAN-CVE-2026-54920","ECHO-d06f-415d-1da1","GHSA-fp75-87pr-8329","MINI-vgv8-7f3r-w66v","SUSE-SU-2026:3168-1","UBUNTU-CVE-2026-54920"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenEXR image library","requires_auth":"none","summary":"A crafted HTJ2K-compressed EXR file causes a process abort in applications using OpenEXR, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-824","name":"Access of Uninitialized Pointer"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions 3.4.0 through 3.4.12, a reachable assertion failure in the HTJ2K decode path allows a crafted HTJ2K-compressed EXR file to cause an unconditional process abort in any application that calls exr_start_read() on untrusted input, resulting in denial of service. The crash is triggered by a QCD marker whose lower five bits are zero, which OpenEXR passes into the vendored OpenJPH library while constructing the codestream and evaluating its quantization delta parameters. OpenJPH uses an assertion rather than a recoverable error to validate those bits, so any invalid value calls abort() directly and cannot be intercepted by surrounding error handling, a problem compounded by OpenEXR wrapping only its internal HT header parser in error handling while leaving the later codestream read and construction calls unprotected. This issue has been resolved in version 3.4.13.","ecosystems":["SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenEXR: Integer overflow and uninitialized pointer cause invalid delete in OpenEXRUtil image resize","id":"CVE-2026-54920","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Visual Studio Code Python Extension Security Feature Bypass Vulnerability","id":"CVE-2026-54981"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["2.1.0-6.48.1"],"introduced":["0"],"last_affected":[],"package":"openexr","purl":"pkg:rpm/suse/openexr\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:3168-1"}],"prev":{"headline":"cpp-httplib: TLS certificate chain verification bypassed for IP-literal hosts on Mbed TLS and wolfSSL backends","id":"CVE-2026-54919"},"products":["openexr"],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["AcademySoftwareFoundation"]},"summary":"A crafted HTJ2K-compressed EXR file causes a process abort in applications using OpenEXR, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-54920/"}