# CVE-2026-54920: OpenEXR: Integer overflow and uninitialized pointer cause invalid delete in OpenEXRUtil image resize

> A crafted HTJ2K-compressed EXR file causes a process abort in applications using OpenEXR, leading to denial of service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** AZL-97620, BELL-CVE-2026-54920, DEBIAN-CVE-2026-54920, ECHO-d06f-415d-1da1, GHSA-fp75-87pr-8329, MINI-vgv8-7f3r-w66v, SUSE-SU-2026:3168-1, UBUNTU-CVE-2026-54920

## What is CVE-2026-54920?

CVE-2026-54920 is a denial of service vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions 3.4.0 through 3.4.12, a reachable assertion failure in the HTJ2K decode path allows a crafted HTJ2K-compressed EXR file to cause an unconditional process abort in any application that calls exr_start_read() on untrusted input, resulting in denial of service. The crash is triggered by a QCD marker whose lower five bits are zero, which OpenEXR passes into the vendored OpenJPH library while constructing the codestream and evaluating its quantization delta parameters. OpenJPH uses an assertion rather than a recoverable error to validate those bits, so any invalid value calls abort() directly and cannot be intercepted by surrounding error handling, a problem compounded by OpenEXR wrapping only its internal HT header parser in error handling while leaving the later codestream read and construction calls unprotected. This issue has been resolved in version 3.4.13.

Weakness: CWE-824 (Access of Uninitialized Pointer), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-54920?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.1.0-6.48.1 |

## How do I fix CVE-2026-54920?

Upgrade to a fixed version.

## Is CVE-2026-54920 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54920 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54920 and fix it if it is affected.

What it is: CVE-2026-54920 is a denial of service vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54920 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54920/ (Markdown: https://insights.sbomify.com/CVE-2026-54920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54920
- OSV: https://osv.dev/vulnerability/CVE-2026-54920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54920/
Summaries are generated and may contain mistakes; the official description above is the record.
