# CVE-2026-5497: Unbounded Frame Count in video/jpeg Base64 Data URL Processing Leads to OOM DoS in vllm-project/vllm

> An attacker can cause a denial of service in vLLM by sending a crafted request with excessive JPEG frames, leading to memory exhaustion.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-wcwg-c5fc-9vrc, PYSEC-2026-2302

## What is CVE-2026-5497?

CVE-2026-5497 is a high-severity denial of service vulnerability in Vllm Vllm, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM versions 0.8.0 and later are vulnerable to an Out-of-Memory (OOM) Denial of Service (DoS) attack due to unbounded frame count processing in the `VideoMediaIO.load_base64()` method. When processing `video/jpeg` data URLs, the method splits the base64 data string on commas to extract individual JPEG frames without enforcing a frame count limit. An attacker can exploit this by crafting a single API request containing thousands of comma-separated base64-encoded JPEG frames in a data URL, causing the server to decode all frames into memory and crash due to excessive memory consumption. This vulnerability is reachable via the OpenAI-compatible chat completions API and does not require authentication.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-5497?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.8.0 | 0.19.0 |
| `vllm` | PyPI | From 0.8.0 | 0.19.0 |
| `vllm` | PyPI | From 0.8.0 | 0.19.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-5497?

Upgrade vllm to 0.19.0 or later.

## Is CVE-2026-5497 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5497 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5497 and fix it if it is affected.

What it is: CVE-2026-5497 is a high-severity denial of service vulnerability in Vllm Vllm, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5497 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.8.0; fixed in 0.19.0
- vllm (PyPI): affected from 0.8.0; fixed in 0.19.0
- vllm (PyPI): affected from 0.8.0; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5497/ (Markdown: https://insights.sbomify.com/CVE-2026-5497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5497
- OSV: https://osv.dev/vulnerability/CVE-2026-5497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5497/
Summaries are generated and may contain mistakes; the official description above is the record.
