# CVE-2026-55059: OpenEXR: OpenEXRUtil SampleCountChannel row setter heap has an out-of-bounds write vulnerability

> A heap out-of-bounds write in OpenEXR allows attackers to cause crashes or potentially execute code via crafted deep image files.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** AZL-97626, BELL-CVE-2026-55059, CLSA-2026-1792587918, DEBIAN-CVE-2026-55059, ECHO-460b-2c90-9266, GHSA-54cp-3rq6-7mq8, MINI-9qh6-rwrh-6hv2, UBUNTU-CVE-2026-55059

## What is CVE-2026-55059?

CVE-2026-55059 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. Versions prior to 3.2.10, 3.3.12 and 3.4.13 contain a heap out-of-bounds write in Imf_4_0::SampleCountChannel::set(int r, unsigned int newNumSamples[]). The row-based sample-count setter computes the target Y coordinate with dataWindow.min.x instead of dataWindow.min.y. For a valid deep image data window where min.x != min.y, a valid row index can be translated into an invalid Y coordinate, causing writes before the allocated _numSamples buffer. The vulnerability is reachable through the public OpenEXRUtil DeepImage API and can lead to heap corruption and process crashes. This issue has been fixed in versions 3.2.10, 3.3.12 and 3.4.13.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-55059?


## How do I fix CVE-2026-55059?

Upgrade to a fixed version.

## Is CVE-2026-55059 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55059 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55059 and fix it if it is affected.

What it is: CVE-2026-55059 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55059 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55059/ (Markdown: https://insights.sbomify.com/CVE-2026-55059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55059
- OSV: https://osv.dev/vulnerability/CVE-2026-55059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55059/
Summaries are generated and may contain mistakes; the official description above is the record.
