# CVE-2026-55073: WeasyPrint restrictive URL fetcher bypass allows local file read and SSRF

> Attackers can bypass URL restrictions in WeasyPrint to read local files or access internal resources via crafted PDF generation inputs.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-55073, GHSA-jf6q-chmf-3h3v, PYSEC-2026-3940, UBUNTU-CVE-2026-55073, openSUSE-SU-2026:11816-1, openSUSE-SU-2026:21928-1

## What is CVE-2026-55073?

CVE-2026-55073 is a medium-severity server-side request forgery vulnerability in Kozea WeasyPrint, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

WeasyPrint helps web developers to create PDF documents. Prior to 70.0, server-side applications that configure a restrictive url_fetcher and pass attacker-influenced values to HTML.write_pdf() can have the restriction bypassed through the xmp_metadata or stylesheets options. In weasyprint/pdf/init.py, xmp_metadata calls select_source() without the document url_fetcher, allowing an accessible local file to be read and embedded verbatim in the output PDF. In weasyprint/document.py, stylesheets constructs CSS() without the document url_fetcher, allowing local or internal resource loading and propagating the permissive fetcher through nested CSS imports and url() references. The stylesheets channel applies fetched resources but does not by itself disclose stylesheet comments verbatim. This issue is fixed in version 70.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-55073?

3 open source packages ship an affected version, including weasyprint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weasyprint` | PyPI | All versions | 70.0 |
| `weasyprint` | PyPI | All versions | 70.0 |
| `weasyprint` | PyPI | All versions | 70.0 |
| `python-weasyprint` | openSUSE:Leap 16.0 | All versions | 65.1-bp160.4.1 |
| `python-weasyprint` | openSUSE:Tumbleweed | All versions | 70.0-1.1 |

## How do I fix CVE-2026-55073?

Upgrade weasyprint to 70.0 or later.

## Is CVE-2026-55073 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55073 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55073 and fix it if it is affected.

What it is: CVE-2026-55073 is a medium-severity server-side request forgery vulnerability in Kozea WeasyPrint, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55073 exists.

Affected packages and fixed versions:
- weasyprint (PyPI): affected all versions; fixed in 70.0
- weasyprint (PyPI): affected all versions; fixed in 70.0
- weasyprint (PyPI): affected all versions; fixed in 70.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55073/ (Markdown: https://insights.sbomify.com/CVE-2026-55073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55073
- OSV: https://osv.dev/vulnerability/CVE-2026-55073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55073/
Summaries are generated and may contain mistakes; the official description above is the record.
