CVE-2026-55074 Ansible FreeBSD Jail Connection Plugin: Jail escape via symlink following in put_file (host-side root mv)

High 8.2 Published Updated

A jail escape vulnerability allows attackers with jail access to perform arbitrary root-owned writes on the host via symlink following, leading to host compromise.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55074?

CVE-2026-55074 is a high-severity path traversal vulnerability in chofstede ansible_jailexec, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Ansible FreeBSD Jail Connection Plugin is an Ansible connection plugin for FreeBSD Jails via jexec. Through version 1.3.0, the jailexec connection plugin's put_file resolved a transfer's destination to a path on the jail host ( + ) and ran mkdir -p and mv there as root on the host. Those commands follow symbolic links, and the path was operated on outside the jail, so a symlink existing inside the jail was followed by the host-side, root-privileged mv. A party controlling content inside a managed jail (the jail's root, or any process able to create a symlink in a directory an Ansible task later writes to) can therefore cause an arbitrary root-owned write on the host, outside the jail — a full jail escape. Arbitrary root-owned host writes are readily escalated to host compromise (e.g. cron, rc.d, authorized_keys). Preconditions for this vulnerability are that the operator runs a copy/template/fetch-style task (anything using put_file) against the jail, and the attacker can place a symlink inside the jail at or above the task's destination before the transfer runs. This issue has been fixed in version 2.0.0.

Weakness: CWE-59

Which versions are affected by CVE-2026-55074?

3 open source packages ship an affected version, including ansible-jailexec.

PackageAffectedFixed in
ansible-jailexec PyPIAll versions2.0.0
ansible-jailexec PyPIAll versions2.0.0
ansible-jailexec PyPIAll versions2.0.0

How do I fix CVE-2026-55074?

Upgrade ansible-jailexec to 2.0.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-55074 being exploited?

There is no known exploitation of CVE-2026-55074 in the wild and no public exploit code.

Sources

Also known as GHSA-cxgv-hp74-jj7r, PYSEC-2026-3658.

Is CVE-2026-55074 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free