# CVE-2026-55077: Coder: User-admin role can reset owner account password

> A user-admin can reset an owner's password without current credentials, enabling account takeover and privilege escalation in Coder deployments.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-29xf-69gq-m9jx, GO-2026-5906

## What is CVE-2026-55077?

CVE-2026-55077 is a high-severity vulnerability in coder, published on 7 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, the `PUT /api/v2/users/{user}/password` endpoint authorized only `ActionUpdatePersonal` and did not prevent a `user-admin` from resetting an `owner` account's password. It also did not require the current password when an admin reset another user's password. Exploitation requires the privileged `user-admin` role so practical risk is limited to deployments that grant `user-admin` to less trusted operators. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 prevents non-owner users from resetting the password of an account that holds the `owner` role. As a workaround, restrict the `user-admin` role to trusted administrators.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-55077?

10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder` | Go | All versions | None |

Products: Coder Coder.

## How do I fix CVE-2026-55077?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.

## Is CVE-2026-55077 being exploited?

There is no known exploitation of CVE-2026-55077 in the wild and no public exploit code.

## Other vulnerabilities in coder

- [CVE-2026-46354](https://insights.sbomify.com/CVE-2026-46354/): Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft (critical 9.1)
- [CVE-2026-55429](https://insights.sbomify.com/CVE-2026-55429/): Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID (high 8.7)
- [CVE-2026-55427](https://insights.sbomify.com/CVE-2026-55427/): Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh` (high 8.3)
- [CVE-2026-55428](https://insights.sbomify.com/CVE-2026-55428/): Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator (high 8.2)
- [CVE-2024-27918](https://insights.sbomify.com/CVE-2024-27918/): Coder's OIDC authentication allows email with partially matching domain to register (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55077 and fix it if it is affected.

What it is: CVE-2026-55077 is a high-severity vulnerability in coder, published on 7 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55077 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17, 2.32.7, 2.33.8, 2.34.2
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55077/ (Markdown: https://insights.sbomify.com/CVE-2026-55077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55077
- OSV: https://osv.dev/vulnerability/CVE-2026-55077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55077/
Summaries are generated and may contain mistakes; the official description above is the record.
