# CVE-2026-55083: DHIS2: Unsafe Java Deserialization - Remote Code Execution (RCE)

> Remote attackers can execute arbitrary code on DHIS2 servers by exploiting unsafe Java deserialization vulnerabilities.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-3fr2-wvqx-cmr5

## What is CVE-2026-55083?

CVE-2026-55083 is a critical unsafe deserialization vulnerability in dhis2-core, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

DHIS2 is a flexible information system for data capture, management, validation, analytics and visualization. From versions 2.42.0 to before 2.42.5.1, and from versions 2.43.0 to before 2.43.0.1, DHIS2 is vulnerable to remote code execution (RCE) via unsafe Java deserialization. This issue has been patched in versions 2.42.5.1, 2.43.0.1, and 2.44.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-55083?


## How do I fix CVE-2026-55083?

No fix has been published for CVE-2026-55083 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55083 being exploited?

There is no known exploitation of CVE-2026-55083 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55083 and fix it if it is affected.

What it is: CVE-2026-55083 is a critical unsafe deserialization vulnerability in dhis2-core, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55083 in the wild and no public exploit code.

Affected product: dhis2-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55083/ (Markdown: https://insights.sbomify.com/CVE-2026-55083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55083
- OSV: https://osv.dev/vulnerability/CVE-2026-55083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55083/
Summaries are generated and may contain mistakes; the official description above is the record.
