# CVE-2026-55085: Etherpad: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in etherpad-lite

> An attacker with write access can inject malicious scripts via crafted imports, leading to XSS when other users view the pad.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-f7h5-v9hm-548j

## What is CVE-2026-55085?

CVE-2026-55085 is a critical cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Etherpad is a real-time collaborative editor. Prior to 3.3.1, result.appendSpan in src/static/js/domline.ts interpolates the start attribute of a numbered list directly into an unquoted ol start attribute before assigning the generated markup to node.innerHTML. ImportEtherpad.setPadRaw in src/node/utils/ImportEtherpad.ts accepts attacker-controlled attribute-pool values from a crafted .etherpad import, including list:number1 and a malicious start value. Any user with write access to a pad can store markup that executes as cross-site scripting when another user opens the pad or /timeslider, including when an administrator views the pad. This issue is fixed in version 3.3.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55085?


## How do I fix CVE-2026-55085?

No fix has been published for CVE-2026-55085 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55085 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55085 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55085 and fix it if it is affected.

What it is: CVE-2026-55085 is a critical cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55085 exists.

Affected product: etherpad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55085/ (Markdown: https://insights.sbomify.com/CVE-2026-55085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55085
- OSV: https://osv.dev/vulnerability/CVE-2026-55085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55085/
Summaries are generated and may contain mistakes; the official description above is the record.
