# CVE-2026-55086: ep_etherpad-lite: Import/export uses Math.random() for temp file paths; predictable paths on shared /tmp enable symlink-based file overwrite

> A local attacker can predict temporary file paths to create symlinks, allowing them to overwrite arbitrary files writable by the Etherpad process.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-2jwf-f4xq-f24h

## What is CVE-2026-55086?

CVE-2026-55086 is a medium-severity path traversal vulnerability in etherpad, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Etherpad is a real-time collaborative editor. Prior to 3.1.0, src/node/handler/ImportHandler.ts and src/node/handler/ExportHandler.ts derive temporary filenames from Math.random() and place them in os.tmpdir(). On a host with a shared world-writable temporary directory, a local unprivileged attacker who predicts a filename can precreate a symbolic link to a file writable by the Etherpad process. Subsequent import or export operations can follow the link through fs.writeFile, fs.rename, or document-conversion output and overwrite the target with partially attacker-controlled content. This issue is fixed in version 3.1.0.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2026-55086?

2 open source packages ship an affected version, including ep_etherpad-lite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ep_etherpad-lite` | npm | All versions | 3.1.0 |
| `ep_etherpad-lite` | npm | All versions | 3.1.0 |

## How do I fix CVE-2026-55086?

Upgrade ep_etherpad-lite to 3.1.0 or later.

## Is CVE-2026-55086 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55086 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55086 and fix it if it is affected.

What it is: CVE-2026-55086 is a medium-severity path traversal vulnerability in etherpad, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55086 exists.

Affected packages and fixed versions:
- ep_etherpad-lite (npm): affected all versions; fixed in 3.1.0
- ep_etherpad-lite (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55086/ (Markdown: https://insights.sbomify.com/CVE-2026-55086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55086
- OSV: https://osv.dev/vulnerability/CVE-2026-55086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55086/
Summaries are generated and may contain mistakes; the official description above is the record.
