CVE-2026-55087 ep_etherpad-lite: Cache-poisoning Cross-site Scripting and Open Redirect via x-proxy-path Header
Attackers can inject scripts into admin pages via the x-proxy-path header, leading to XSS and potential cache poisoning in Etherpad deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55087?
CVE-2026-55087 is a medium-severity cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Etherpad is a real-time collaborative editor. From 2.1.0 until 3.1.0, Etherpad uses the attacker-controlled x-proxy-path request header in src/node/hooks/express/admin.ts when substituting paths into HTML, JavaScript, and CSS under /admin without sanitization, Vary: x-proxy-path, or Cache-Control: private, no-store. A shared proxy or CDN can cache the resulting response and serve attacker-injected script to an administrator. In src/node/hooks/express/specialpages.ts, version 3.0.0 also accepts a protocol-relative x-proxy-path value when constructing the /p/:pad/timeslider redirect, allowing redirection to an attacker-controlled host. The issues are exploitable when the deployment permits client-supplied x-proxy-path headers to reach Etherpad. This issue is fixed in version 3.1.0.
Which versions are affected by CVE-2026-55087?
2 open source packages ship an affected version, including ep_etherpad-lite.
| Package | Affected | Fixed in |
|---|---|---|
ep_etherpad-lite npm | From 2.1.0 | 3.1.0 |
ep_etherpad-lite npm | From 2.1.0 | 3.1.0 |
How do I fix CVE-2026-55087?
Upgrade ep_etherpad-lite to 3.1.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-55087 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55087 exists.
Public exploit code: 1 Nuclei template.
Sources
Also known as GHSA-fjgc-3mj7-8rg8.