{"answers":{"affected":"2 open source packages ship an affected version, including ep_etherpad-lite.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55087 exists.","fix":"Upgrade ep_etherpad-lite to 3.1.0 or later.","what":"CVE-2026-55087 is a medium-severity cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55087 and fix it if it is affected.\n\nWhat it is: CVE-2026-55087 is a medium-severity cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55087 exists.\n\nAffected packages and fixed versions:\n- ep_etherpad-lite (npm): affected from 2.1.0; fixed in 3.1.0\n- ep_etherpad-lite (npm): affected from 2.1.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55087/ (Markdown: https://insights.sbomify.com/CVE-2026-55087/index.md)","id":"CVE-2026-55087","markdown":"https://insights.sbomify.com/CVE-2026-55087/index.md","name":"CVE-2026-55087","record":{"aliases":["GHSA-fjgc-3mj7-8rg8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Etherpad collaborative editor","requires_auth":"none","summary":"Attackers can inject scripts into admin pages via the x-proxy-path header, leading to XSS and potential cache poisoning in Etherpad deployments.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Etherpad is a real-time collaborative editor. From 2.1.0 until 3.1.0, Etherpad uses the attacker-controlled x-proxy-path request header in src/node/hooks/express/admin.ts when substituting paths into HTML, JavaScript, and CSS under /admin without sanitization, Vary: x-proxy-path, or Cache-Control: private, no-store. A shared proxy or CDN can cache the resulting response and serve attacker-injected script to an administrator. In src/node/hooks/express/specialpages.ts, version 3.0.0 also accepts a protocol-relative x-proxy-path value when constructing the /p/:pad/timeslider redirect, allowing redirection to an attacker-controlled host. The issues are exploitable when the deployment permits client-supplied x-proxy-path headers to reach Etherpad. This issue is fixed in version 3.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-55087.yaml","stars":null,"title":"Etherpad 2.1.0 \u003c= 3.0.0 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"ep_etherpad-lite: Cache-poisoning Cross-site Scripting and Open Redirect via x-proxy-path Header","id":"CVE-2026-55087","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"ep_etherpad-lite: Device-to-device author-token transfer endpoint is replayable, never expires, and exposes the cleartext author token","id":"CVE-2026-55088"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.1.0"],"last_affected":[],"package":"ep_etherpad-lite","purl":null,"source":"GHSA-fjgc-3mj7-8rg8"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["2.1.0"],"last_affected":[],"package":"ep_etherpad-lite","purl":"pkg:npm/ep_etherpad-lite","source":"GHSA-fjgc-3mj7-8rg8"}],"prev":{"headline":"ep_etherpad-lite: Import/export uses Math.random() for temp file paths; predictable paths on shared /tmp enable symlink-based file overwrite","id":"CVE-2026-55086"},"products":["etherpad"],"published":"2026-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["ether"]},"summary":"Attackers can inject scripts into admin pages via the x-proxy-path header, leading to XSS and potential cache poisoning in Etherpad deployments.","url":"https://insights.sbomify.com/CVE-2026-55087/"}