# CVE-2026-55087: ep_etherpad-lite: Cache-poisoning Cross-site Scripting and Open Redirect via x-proxy-path Header

> Attackers can inject scripts into admin pages via the x-proxy-path header, leading to XSS and potential cache poisoning in Etherpad deployments.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-fjgc-3mj7-8rg8

## What is CVE-2026-55087?

CVE-2026-55087 is a medium-severity cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Etherpad is a real-time collaborative editor. From 2.1.0 until 3.1.0, Etherpad uses the attacker-controlled x-proxy-path request header in src/node/hooks/express/admin.ts when substituting paths into HTML, JavaScript, and CSS under /admin without sanitization, Vary: x-proxy-path, or Cache-Control: private, no-store. A shared proxy or CDN can cache the resulting response and serve attacker-injected script to an administrator. In src/node/hooks/express/specialpages.ts, version 3.0.0 also accepts a protocol-relative x-proxy-path value when constructing the /p/:pad/timeslider redirect, allowing redirection to an attacker-controlled host. The issues are exploitable when the deployment permits client-supplied x-proxy-path headers to reach Etherpad. This issue is fixed in version 3.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-601 (URL Redirection to Untrusted Site), CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-55087?

2 open source packages ship an affected version, including ep_etherpad-lite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ep_etherpad-lite` | npm | From 2.1.0 | 3.1.0 |
| `ep_etherpad-lite` | npm | From 2.1.0 | 3.1.0 |

## How do I fix CVE-2026-55087?

Upgrade ep_etherpad-lite to 3.1.0 or later.

## Is CVE-2026-55087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55087 exists.

Public exploit code:

- Etherpad 2.1.0 <= 3.0.0 - Cross-Site Scripting (nuclei): http/cves/2026/CVE-2026-55087.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55087 and fix it if it is affected.

What it is: CVE-2026-55087 is a medium-severity cross-site scripting vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55087 exists.

Affected packages and fixed versions:
- ep_etherpad-lite (npm): affected from 2.1.0; fixed in 3.1.0
- ep_etherpad-lite (npm): affected from 2.1.0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55087/ (Markdown: https://insights.sbomify.com/CVE-2026-55087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55087
- OSV: https://osv.dev/vulnerability/CVE-2026-55087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55087/
Summaries are generated and may contain mistakes; the official description above is the record.
