# CVE-2026-55088: ep_etherpad-lite: Device-to-device author-token transfer endpoint is replayable, never expires, and exposes the cleartext author token

> Unauthenticated attackers can replay token transfer requests to steal cleartext author tokens and impersonate users in Etherpad.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-vqfp-p66c-xrp9

## What is CVE-2026-55088?

CVE-2026-55088 is a medium-severity vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Etherpad is a real-time collaborative editor. From 2.6.0 until 3.1.0, Etherpad's src/node/hooks/express/tokenTransfer.ts uses POST /tokenTransfer to store an author token for transfer between browsers and exposes it through GET /tokenTransfer/{uuid}. Although the record includes createdAt, the transfer has no expiration check, is not removed after successful redemption, and is returned by res.send(tokenData), including the raw author token. An unauthenticated attacker who obtains a transfer UUID can repeatedly redeem it, receive fresh author cookies, read the cleartext token, and impersonate the originating author for pad read and write operations. This issue is fixed in version 3.1.0.

Weakness: CWE-294 (Authentication Bypass by Capture-replay), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55088?

2 open source packages ship an affected version, including ep_etherpad-lite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ep_etherpad-lite` | npm | From 2.6.0 | 3.1.0 |
| `ep_etherpad-lite` | npm | From 2.6.0 | 3.1.0 |

## How do I fix CVE-2026-55088?

Upgrade ep_etherpad-lite to 3.1.0 or later.

## Is CVE-2026-55088 being exploited?

There is no known exploitation of CVE-2026-55088 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55088 and fix it if it is affected.

What it is: CVE-2026-55088 is a medium-severity vulnerability in etherpad, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55088 in the wild and no public exploit code.

Affected packages and fixed versions:
- ep_etherpad-lite (npm): affected from 2.6.0; fixed in 3.1.0
- ep_etherpad-lite (npm): affected from 2.6.0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55088/ (Markdown: https://insights.sbomify.com/CVE-2026-55088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55088
- OSV: https://osv.dev/vulnerability/CVE-2026-55088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55088/
Summaries are generated and may contain mistakes; the official description above is the record.
