# CVE-2026-55090: Etherpad: Stored XSS in HTML export via unescaped attribute-pool values


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-2jp7-wwpg-3p9w

## What is CVE-2026-55090?

CVE-2026-55090 is a medium-severity vulnerability in etherpad, published on 19 Aug 2026. 

### Official description

Etherpad is a real-time collaborative editor. Prior to 3.3.0, getHTMLFromAtext in src/node/utils/ExportHtml.ts interpolates values from the exportHtmlAdditionalTagsWithData plugin hook into span data attributes without HTML attribute escaping. A pad editor can place an attacker-controlled value into the attribute pool through moveOpsToNewPool and AttributePool.putAttrib. When a bundled plugin such as ep_font_color or ep_font_size registers the hook, opening the resulting HTML export causes the value to execute as stored cross-site scripting in the Etherpad origin. This issue is fixed in version 3.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55090?

2 open source packages ship an affected version, including ep_etherpad-lite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ep_etherpad-lite` | npm | All versions | 3.3.0 |
| `ep_etherpad-lite` | npm | All versions | 3.3.0 |

## How do I fix CVE-2026-55090?

Upgrade ep_etherpad-lite to 3.3.0 or later.

## Is CVE-2026-55090 being exploited?

There is no known exploitation of CVE-2026-55090 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55090 and fix it if it is affected.

What it is: CVE-2026-55090 is a medium-severity vulnerability in etherpad, published on 19 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-55090 in the wild and no public exploit code.

Affected packages and fixed versions:
- ep_etherpad-lite (npm): affected all versions; fixed in 3.3.0
- ep_etherpad-lite (npm): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55090/ (Markdown: https://insights.sbomify.com/CVE-2026-55090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55090
- OSV: https://osv.dev/vulnerability/CVE-2026-55090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55090/
Summaries are generated and may contain mistakes; the official description above is the record.
