{"answers":{"affected":"2 open source packages ship an affected version, including hashi-vault-js.","exploited":"There is no known exploitation of CVE-2026-55100 in the wild and no public exploit code.","fix":"Upgrade hashi-vault-js to 0.5.2 or later.","what":"CVE-2026-55100 is a high-severity path traversal vulnerability in kyndryl-open-source hashi-vault-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55100 and fix it if it is affected.\n\nWhat it is: CVE-2026-55100 is a high-severity path traversal vulnerability in kyndryl-open-source hashi-vault-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55100 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hashi-vault-js (npm): affected all versions; fixed in 0.5.2\n- hashi-vault-js (npm): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55100/ (Markdown: https://insights.sbomify.com/CVE-2026-55100/index.md)","id":"CVE-2026-55100","markdown":"https://insights.sbomify.com/CVE-2026-55100/index.md","name":"CVE-2026-55100","record":{"aliases":["GHSA-g956-2f74-rmv7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Vault client","requires_auth":"none","summary":"Attackers can manipulate Vault API requests via path traversal and query injection due to missing input encoding in the hashi-vault-js library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"hashi-vault-js is a Node.js module for interacting with the HashiCorp Vault API. Prior to 0.5.2, src/Vault.js concatenates unencoded identifier values including name, username, group, role, and version into Vault request paths and query strings instead of using encodeURIComponent() and URLSearchParams, allowing path traversal and query parameter injection. This issue is fixed in version 0.5.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"hashi-vault-js has a path traversal and query parameter injection","id":"CVE-2026-55100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"hashi-vault-js: Vault token and secret values exposed in thrown errors","id":"CVE-2026-55102"},"packages":[{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"hashi-vault-js","purl":null,"source":"GHSA-g956-2f74-rmv7"},{"ecosystem":"npm","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"hashi-vault-js","purl":"pkg:npm/hashi-vault-js","source":"GHSA-g956-2f74-rmv7"}],"prev":{"headline":"icalendar: Algorithmic Complexity in Equality","id":"CVE-2026-55099"},"products":["hashi-vault-js"],"published":"2026-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-31","vendors":["kyndryl-open-source"]},"summary":"Attackers can manipulate Vault API requests via path traversal and query injection due to missing input encoding in the hashi-vault-js library.","url":"https://insights.sbomify.com/CVE-2026-55100/"}