# CVE-2026-55100: hashi-vault-js has a path traversal and query parameter injection

> Attackers can manipulate Vault API requests via path traversal and query injection due to missing input encoding in the hashi-vault-js library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-g956-2f74-rmv7

## What is CVE-2026-55100?

CVE-2026-55100 is a high-severity path traversal vulnerability in kyndryl-open-source hashi-vault-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hashi-vault-js is a Node.js module for interacting with the HashiCorp Vault API. Prior to 0.5.2, src/Vault.js concatenates unencoded identifier values including name, username, group, role, and version into Vault request paths and query strings instead of using encodeURIComponent() and URLSearchParams, allowing path traversal and query parameter injection. This issue is fixed in version 0.5.2.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-55100?

2 open source packages ship an affected version, including hashi-vault-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hashi-vault-js` | npm | All versions | 0.5.2 |
| `hashi-vault-js` | npm | All versions | 0.5.2 |

## How do I fix CVE-2026-55100?

Upgrade hashi-vault-js to 0.5.2 or later.

## Is CVE-2026-55100 being exploited?

There is no known exploitation of CVE-2026-55100 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55100 and fix it if it is affected.

What it is: CVE-2026-55100 is a high-severity path traversal vulnerability in kyndryl-open-source hashi-vault-js, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55100 in the wild and no public exploit code.

Affected packages and fixed versions:
- hashi-vault-js (npm): affected all versions; fixed in 0.5.2
- hashi-vault-js (npm): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55100/ (Markdown: https://insights.sbomify.com/CVE-2026-55100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55100
- OSV: https://osv.dev/vulnerability/CVE-2026-55100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55100/
Summaries are generated and may contain mistakes; the official description above is the record.
