# CVE-2026-55105: Joplin: Fountain embeds allow arbitrary script execution in published notes and the note viewer

> Attackers can execute arbitrary scripts via malicious Fountain code blocks in Joplin notes, potentially reading sensitive data or taking over accounts.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-f7q3-3grx-6wg9

## What is CVE-2026-55105?

CVE-2026-55105 is a high-severity cross-site scripting vulnerability in laurent22 joplin, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Joplin is an open source note-taking and to-do application that organises notes and lists into notebooks. Prior to 3.6.15 and 3.7.2, packages/renderer/MdToHtml/rules/fountain.ts passes HTML generated by the vendored fountain.js renderer into note output without sanitizing it. A malicious Fountain code block can therefore execute script when Fountain rendering is enabled in desktop or mobile clients, or when a note is published through Joplin Server where Fountain rendering is enabled by default. The script can read content subsequently loaded in the reused note viewer or, when published notes are served from the same domain as server content, access data available to an authenticated browser in the server origin. This issue is fixed in versions 3.6.15 and 3.7.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55105?


## How do I fix CVE-2026-55105?

No fix has been published for CVE-2026-55105 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55105 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55105 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55105 and fix it if it is affected.

What it is: CVE-2026-55105 is a high-severity cross-site scripting vulnerability in laurent22 joplin, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55105 exists.

Affected product: laurent22 joplin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55105/ (Markdown: https://insights.sbomify.com/CVE-2026-55105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55105
- OSV: https://osv.dev/vulnerability/CVE-2026-55105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55105/
Summaries are generated and may contain mistakes; the official description above is the record.
