# CVE-2026-55107: Kobako Vulnerable to Sandbox Escape: guest eval reaches host RCE via method_missing → public_send (any bound Service)

> Attackers can escape the Kobako sandbox to execute arbitrary Ruby code on the host by exploiting method_missing and public_send flaws.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-7pwq-q9jf-539h

## What is CVE-2026-55107?

CVE-2026-55107 is a critical code injection vulnerability in elct9620 kobako, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kobako is a Ruby gem that embeds a Wasm-isolated mruby interpreter inside applications, allowing execution of untrusted Ruby scripts (LLM-generated code, user formulas, student submissions, third-party plugins) in-process without giving them access to host memory, files, network, or credentials. From version 0.1.0 to before version 0.9.1, a guest mruby script running inside the Kobako sandbox can execute arbitrary Ruby in the host process, fully escaping the sandbox. This issue has been patched in version 0.9.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-55107?

2 open source packages ship an affected version, including kobako.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kobako` | RubyGems | From 0.1.0 | 0.9.1 |
| `kobako` | RubyGems | From 0.1.0 | 0.9.1 |

## How do I fix CVE-2026-55107?

Upgrade kobako to 0.9.1 or later.

## Is CVE-2026-55107 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55107 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55107 and fix it if it is affected.

What it is: CVE-2026-55107 is a critical code injection vulnerability in elct9620 kobako, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55107 exists.

Affected packages and fixed versions:
- kobako (RubyGems): affected from 0.1.0; fixed in 0.9.1
- kobako (RubyGems): affected from 0.1.0; fixed in 0.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55107/ (Markdown: https://insights.sbomify.com/CVE-2026-55107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55107
- OSV: https://osv.dev/vulnerability/CVE-2026-55107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55107/
Summaries are generated and may contain mistakes; the official description above is the record.
