CVE-2026-55108 KubeVela Terraform remote loader DoS via unbounded file read
An attacker with ComponentDefinition permissions can cause a denial of service by triggering an unbounded file read via symlinks, exhausting memory and crashing the controller.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55108?
CVE-2026-55108 is a high-severity denial of service vulnerability in kubevela, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
KubeVela is an open source application delivery platform. Prior to 1.9.14, from 1.10.0-alpha.1 until 1.10.9, and from 1.11.0-alpha.1 until 1.11.0-alpha.4, the Terraform remote configuration loader in pkg/controller/utils/capability.go, GetTerraformConfigurationFromRemote, clones a repository supplied through a core.oam.dev/v1beta1 ComponentDefinition and follows repository-controlled variables.tf or main.tf symlinks. A user with permission to create or update ComponentDefinition objects can point variables.tf to /dev/zero through terraform.path, after which os.Stat and os.ReadFile follow the link and read an unbounded stream before ParseTerraformVariables or HCL parsing can reject the content. The read can exhaust memory, OOM-kill the cluster-wide vela-core controller, cause repeated Pod restarts, and pressure node memory when no effective container limit is configured. This issue is fixed in versions 1.9.14, 1.10.9, and 1.11.0-alpha.4.
Which versions are affected by CVE-2026-55108?
7 open source packages ship an affected version, including github.com/oam-dev/kubevela.
| Package | Affected | Fixed in |
|---|---|---|
github.com/oam-dev/kubevela Go | All versions | 1.9.14, 1.10.9, 1.11.0-alpha.4 |
github.com/oam-dev/kubevela Go | All versions | 1.9.14 |
github.com/oam-dev/kubevela Go | All versions | 1.9.14 |
github.com/oam-dev/kubevela Go | From 1.10.0-alpha.1 | 1.10.9 |
github.com/oam-dev/kubevela Go | From 1.10.0-alpha.1 | 1.10.9 |
github.com/oam-dev/kubevela Go | From 1.11.0-alpha.1 | 1.11.0-alpha.4 |
1 more packages
github.com/oam-dev/kubevela Go | From 1.11.0-alpha.1 | 1.11.0-alpha.4 |
How do I fix CVE-2026-55108?
Upgrade github.com/oam-dev/kubevela to a fixed version for your release line: 1.9.14, 1.10.9 or 1.11.0-alpha.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-55108 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55108 exists.
Sources
Also known as GHSA-fmgp-q6jx-gg3x, GO-2026-6312.