# CVE-2026-55108: KubeVela Terraform remote loader DoS via unbounded file read

> An attacker with ComponentDefinition permissions can cause a denial of service by triggering an unbounded file read via symlinks, exhausting memory and crashing the controller.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-fmgp-q6jx-gg3x, GO-2026-6312

## What is CVE-2026-55108?

CVE-2026-55108 is a high-severity denial of service vulnerability in kubevela, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KubeVela is an open source application delivery platform. Prior to 1.9.14, from 1.10.0-alpha.1 until 1.10.9, and from 1.11.0-alpha.1 until 1.11.0-alpha.4, the Terraform remote configuration loader in pkg/controller/utils/capability.go, GetTerraformConfigurationFromRemote, clones a repository supplied through a core.oam.dev/v1beta1 ComponentDefinition and follows repository-controlled variables.tf or main.tf symlinks. A user with permission to create or update ComponentDefinition objects can point variables.tf to /dev/zero through terraform.path, after which os.Stat and os.ReadFile follow the link and read an unbounded stream before ParseTerraformVariables or HCL parsing can reject the content. The read can exhaust memory, OOM-kill the cluster-wide vela-core controller, cause repeated Pod restarts, and pressure node memory when no effective container limit is configured. This issue is fixed in versions 1.9.14, 1.10.9, and 1.11.0-alpha.4.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55108?

7 open source packages ship an affected version, including github.com/oam-dev/kubevela.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oam-dev/kubevela` | Go | All versions | 1.9.14, 1.10.9, 1.11.0-alpha.4 |
| `github.com/oam-dev/kubevela` | Go | All versions | 1.9.14 |
| `github.com/oam-dev/kubevela` | Go | All versions | 1.9.14 |
| `github.com/oam-dev/kubevela` | Go | From 1.10.0-alpha.1 | 1.10.9 |
| `github.com/oam-dev/kubevela` | Go | From 1.10.0-alpha.1 | 1.10.9 |
| `github.com/oam-dev/kubevela` | Go | From 1.11.0-alpha.1 | 1.11.0-alpha.4 |
| `github.com/oam-dev/kubevela` | Go | From 1.11.0-alpha.1 | 1.11.0-alpha.4 |

## How do I fix CVE-2026-55108?

Upgrade github.com/oam-dev/kubevela to a fixed version for your release line: 1.9.14, 1.10.9 or 1.11.0-alpha.4.

## Is CVE-2026-55108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55108 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55108 and fix it if it is affected.

What it is: CVE-2026-55108 is a high-severity denial of service vulnerability in kubevela, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55108 exists.

Affected packages and fixed versions:
- github.com/oam-dev/kubevela (Go): affected all versions; fixed in 1.9.14, 1.10.9, 1.11.0-alpha.4
- github.com/oam-dev/kubevela (Go): affected all versions; fixed in 1.9.14
- github.com/oam-dev/kubevela (Go): affected all versions; fixed in 1.9.14
- github.com/oam-dev/kubevela (Go): affected from 1.10.0-alpha.1; fixed in 1.10.9
- github.com/oam-dev/kubevela (Go): affected from 1.10.0-alpha.1; fixed in 1.10.9
- github.com/oam-dev/kubevela (Go): affected from 1.11.0-alpha.1; fixed in 1.11.0-alpha.4
- github.com/oam-dev/kubevela (Go): affected from 1.11.0-alpha.1; fixed in 1.11.0-alpha.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55108/ (Markdown: https://insights.sbomify.com/CVE-2026-55108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55108
- OSV: https://osv.dev/vulnerability/CVE-2026-55108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55108/
Summaries are generated and may contain mistakes; the official description above is the record.
