# CVE-2026-55157: Token Optimizer MCP: OS command injection in smart_user via username in get-user-info

> Attackers can execute arbitrary shell commands via the username argument in the smart_user tool of Token Optimizer MCP.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-49mq-fc6q-3h46

## What is CVE-2026-55157?

CVE-2026-55157 is a high-severity command injection vulnerability in ooples token-optimizer-mcp, published on 28 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Token Optimizer MCP measures token savings per AI coding agent, optimizes context, and shares a live local knowledge graph across 16 CLI clients. Prior to version 5.1.0, token-optimizer-mcp is vulnerable to OS command injection in the smart_user tool. Any MCP client that can call the smart_user tool can execute arbitrary shell commands through the username argument of the get-user-info operation. The commands execute with the privileges of the user running the token-optimizer-mcp server. This issue has been patched in version 5.1.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55157?

2 open source packages ship an affected version, including @ooples/token-optimizer-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ooples/token-optimizer-mcp` | npm | All versions | 5.1.0 |
| `@ooples/token-optimizer-mcp` | npm | All versions | 5.1.0 |

## How do I fix CVE-2026-55157?

Upgrade @ooples/token-optimizer-mcp to 5.1.0 or later.

## Is CVE-2026-55157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55157 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55157 and fix it if it is affected.

What it is: CVE-2026-55157 is a high-severity command injection vulnerability in ooples token-optimizer-mcp, published on 28 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55157 exists.

Affected packages and fixed versions:
- @ooples/token-optimizer-mcp (npm): affected all versions; fixed in 5.1.0
- @ooples/token-optimizer-mcp (npm): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55157/ (Markdown: https://insights.sbomify.com/CVE-2026-55157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55157
- OSV: https://osv.dev/vulnerability/CVE-2026-55157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55157/
Summaries are generated and may contain mistakes; the official description above is the record.
