# CVE-2026-55159: Command injection in luci-app-adblock-fast

> Authenticated users with write access can inject newlines into cron entries to execute arbitrary commands as root on OpenWrt devices.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-ggpf-xrph-wg5v

## What is CVE-2026-55159?

CVE-2026-55159 is a high-severity command injection vulnerability in openwrt luci-app-adblock-fast, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

luci-app-adblock-fast a WebUI for fast, lightweight DNS-based ad-blocker for OpenWrt that works with dnsmasq, smartdns, or unbound. Prior to 1.2.4-2, the luci.adblock-fast.setCronEntry RPC method accepts an entry argument containing carriage-return or line-feed characters and serializes it into /etc/crontabs/root as though it were one logical line. An authenticated delegated user with the luci-app-adblock-fast write ACL can therefore create an additional physical root cron entry through applications/luci-app-adblock-fast/root/usr/share/rpcd/ucode/luci.adblock-fast, resulting in persistent command execution as UID 0 when cron runs. The issue is not demonstrated for unauthenticated callers or users without the component write ACL. This vulnerability is fixed in 1.2.4-2.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-55159?


## How do I fix CVE-2026-55159?

No fix has been published for CVE-2026-55159 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55159 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55159 and fix it if it is affected.

What it is: CVE-2026-55159 is a high-severity command injection vulnerability in openwrt luci-app-adblock-fast, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55159 exists.

Affected product: openwrt luci-app-adblock-fast. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55159/ (Markdown: https://insights.sbomify.com/CVE-2026-55159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55159
- OSV: https://osv.dev/vulnerability/CVE-2026-55159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55159/
Summaries are generated and may contain mistakes; the official description above is the record.
