# CVE-2026-55163: Lemur: Privilege escalation via PUT /api/1/roles/<id> — non-admin role members can rewrite role membership

> Non-admin role members can modify role membership and names, enabling lateral privilege escalation and access denial in Lemur certificate management.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-x3vf-mgxj-7785, PYSEC-2026-2591

## What is CVE-2026-55163?

CVE-2026-55163 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.2, PUT /api/1/roles/ in lemur/roles/views.py:298 authorized updates with RoleMemberPermission(role_id), which allowed either an administrator or any existing member of the target role. The handler passed data["users"] and data["name"] to service.update, allowing a non-admin member to add or remove other users and rename the role. This enabled lateral privilege grants within roles that control certificate and authority access and could deny access by removing legitimate members. The DELETE handler already required admin_permission, confirming that the weaker PUT authorization was inconsistent. The fix applies the same administrator-only requirement to the PUT handler. This issue is fixed in version 1.9.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-55163?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |
| `lemur` | PyPI | All versions | 1.9.2 |

## How do I fix CVE-2026-55163?

Upgrade lemur to 1.9.2 or later.

## Is CVE-2026-55163 being exploited?

There is no known exploitation of CVE-2026-55163 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55163 and fix it if it is affected.

What it is: CVE-2026-55163 is a medium-severity missing authorization vulnerability in Netflix lemur, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55163 in the wild and no public exploit code.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2
- lemur (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55163/ (Markdown: https://insights.sbomify.com/CVE-2026-55163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55163
- OSV: https://osv.dev/vulnerability/CVE-2026-55163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55163/
Summaries are generated and may contain mistakes; the official description above is the record.
